Missing some icons/Emojis

I have some icons/Emojis missing when I open a file locally using Vim/Kate

but on GitHub page (where I pull those file), it shows just fine (using firefox, and I can even select it, but it won’t show if I paste it)

however, some icons shows with no problem locally, e.g.

I have installed fonts including

-> bsh > pacman -Qi ttf-
ttf-bitstream-vera             ttf-hack                       ttf-joypixels                  ttf-nerd-fonts-symbols-common
ttf-dejavu                     ttf-hack-nerd                  ttf-liberation                 ttf-nerd-fonts-symbols-mono
ttf-firacode-nerd              ttf-iosevka-nerd               ttf-nerd-fonts-symbols         ttf-opensans

-> bsh > pacman -Qi noto-fonts
noto-fonts        noto-fonts-emoji  

Any fix for this?
I am using KDE/Wayland, amd cpu and gpu.

What font are you using in konsole? Emoji work for me with Fira Code / Emacs:

Try this line (copy / paste) in konsole:

 echo 🐀 😃 😂 🐱 🐶 😁 🐄 🐸 🇬🇧  

shows like this

and I am not sure what font I am using, I guess fire code also?

Settings >> Edit current profile >> Appearance

It is Fira Code 10pt

btw, just tried medium and Linux colours, not working…

Hmmm, try:

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
   <family>Fira Code</family>
   <!-- Your preferred monospace font -->
   <family>Noto Color Emoji</family>
   <!-- Your preferred emoji font -->

Save as ~/.config/fontconfig/fonts.conf

This is what I have installed:

27 aur/ttf-twemoji 14.0.2-2 (+65 3.12) (Installed: 14.0.2-3)
21 archlinuxcn/ttf-twemoji 14.0.2-3 (2.6 MiB 3.2 MiB) (Installed)
17 chaotic-aur/ttf-twemoji 14.0.2-2 (2.7 MiB 3.2 MiB) (Installed: 14.0.2-3)
14 extra/unicode-emoji 15.0-1 (69.2 KiB 993.9 KiB) (Installed)
13 extra/nodejs-emojione 4.5.0-3 (481.7 KiB 6.3 MiB) (Installed)
2 extra/noto-fonts-emoji 20220920-1 (9.0 MiB 9.9 MiB) (Installed)
1 extra/ttf-joypixels 7.0.0-1 (12.0 MiB 12.9 MiB) (Installed)
1 Like

I install all of them and add fonts.conf, logout and in, now it work! in both konsole and kate, Thanks!

(just wondering, though it works now in konsole and kate, it is still not working on someplace, e.g. in start menu or system search

can this also be fixed?)

Don’t know, never noticed it until you pointed it out and TBH it doesn’t bother me :rofl:

Anyway gone midnight, time for bed… :zzz:

Aha true. Thanks for your help bro!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.