Missing pkg_resources in python

Hey, i just start to use Endeavouros. I’m trying to install dirsearch and for use it i need to execute “dirsearch.py” but when i tried to execute it it say :

so i tried to install Pkg_resources and it say :

(I installed locally the package because when i tried to install with pacman -S python-setuptools and use python-setuptools it didn’t work)

So i don’t know how install pkg_resources for executing dirsearch (i already tried with setup.py and there is another error) I’m totally lost

Thanks for your responds

Tu peut pas installer l’application avec l’aur? je l’ai installer avec yay dirsearch et après un test sur un url ont dirait que tout marche. Peut être que je ne comprend pas bien ton issue?

Tu fais bien python3 dirsearch.py -u https://target quand tu l’utilises non ?

Non, seulement dirsearch -u https://target

Avec ou sans python3 devant j’ai la meme erreur :

Ton screenshot manque le -u

Oui my bad j’ai fais le mauvais screen, j’ai utilisé le -u j’ai quand même eu la même erreur

même quand je fais un --version ou -h j’ai les mêmes erreurs

hmm j’ai fait un autre test avec une address http et ca marche quand même. T’as installer comment? Avec yay?

Oui j’ai fais ça :

Ah, d’accord tu a installer dirsearch-git. Essaye de désinstaller celui la et installe la premiere option dirsearch pour voir si ca marche mieux.

1 Like

Enfin ca fonctionne ! merci :smile:

1 Like

Aucun problème, bonne soirée! :slight_smile:

1 Like

Merci, toi aussi !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.