Missing panel icons

Hi everyone! So my panel icons gone missing. I mean bluetooth, Wi-fi and some running programs icons (like octopi or toggl track).
The ones which used to be here:
Any ideas why they are gone and how could I bring them back?


Have you tried another theme?

It helped, but broke some other stuff, like keyboard switch, layouts screen setup etc. Is it normal behaviour? Also all the left side panel icons were gone but I guess it should be like this. Need to do some job related stuff so atm I went back to the backup theme and will try to find some working solution later.

Icons shouldn’t disappear completely; if an icon theme is missing an icon (it really shouldn’t btw, not for panel plugins for normal functions like bluetooth) it should default to adwaita theme for the icons in question.

Are you 100% sure you haven’t set Bluetooth to not show an icon when turned off, or at all?

I’m positive. Moreover it’s not just Bluetooth. It’s Bluetooth, Wi-Fi and a number of apps’ tray icons. Switching themes to default helped but brought new problems though.

I’ve seen something similar recently. Took me a while but I eventually worked out that it was the systray closing (been renamed to “Status Tray”). In my case, I use Teamviewer to support a couple of people remotely, starting it was killing the tray every time. At least with Teamviewer, I got a warning that it had “left”. I’ve seen some mention of a but being raised on the Xfce forum, can’t recall the number or how close they are to a fix.

Bluetooth icons and network manager both use the system tray for display.

1 Like

Huh? How did you solve it? If I understood you correctly I need to stop system tray form closing? If it’s the case I think it is closed even on system boot.

Can’t say I have really solved it. There seems to be more than one bug. First time I hit it was using Teamviewer to support a customer. In that instance, a warning box pops up saying that “status tray” failed to execute and offering a retry or remove option. If you take the remove option, it gets dropped from the panel. In my case, the retry option just kept coming back to the same option box. All I could do was get the notification box out of the way, and when I finished the teamviewer session, retry again. That got it back to normal.

Yesterday I found another error. My desktop machine wasn’t showing the pamac icon. I’d been having problems with pamac on that machine, so thought it was more errors from it. However, I wondered if the status tray had stopped as it had with teamviewer. When I tried to reload it (panel > add new items) I found it was grayed out and not available - it was still running, but no longer visible. Logging out and back in again didn’t help, but a restart brought it back.

For the moment, I suspect you’re going to have to put up with it until the Xfce devs sort the problem out and release a fixed version.

Ok, now we are getting somewhere as I also have installed teamviewer last week and had similar experince. Reloading didn’t help, so I tried stopping guess that broke other icons and widgets.

I have been through this problem, namely:
Installing Xfce4 from the iso there are not and should not be any icon problems, everything is perfect.
Now then; installing Xfce4 or any other desktop from an already established desktop, as for example, I was using Plasma and when I installed all the Xfce4 packages when I restarted I didn’t find the wifi icons, clock. although if I had wifi I suppose it came from the Plasma installation, and the same happens with Mate, the icons are missing or it must be a mistake on my part …
I haven’t found the solution, just install from scratch with the iso /eOS

Thanks to everyone for the help. So I found the solution. Teamviewer is glitchy and it breaks the systray, so you just need to restart it after using the teamviewer. Simple as that.