Missing network manager after uninstalling GNOME

Heyas. So, I got Plasma to work just the way I want, and don’t feel the need for GNOME any more, so I uninstalled it. But I think I fucked it up somehow and also uninstalled my network manager, along other things. Couldn’t get them back either, because they were not in cache and couldn’t download them because there was no internet.

What I did to fix things:

  1. Created a Wired Network on systemd-netwrkd

“sudo nano /etc/systemd/network/20-wired.network”

  1. Pasted the following in the file (without quotes):



  1. Quit nano and saved the file

  2. Enabled systemd-networkd and systemd-resolved services

“sudo systemctl enable systemd-networkd.service
sudo systemctl enable systemd-resolved.service”

  1. Rebooted

Now there was a way to connect to the internet using USB tethering on my phone & I guess wired connection would’ve worked too.

  1. Installed networkmanager

“sudo pacman -S networkmanager”

  1. Enabled the NetworkManager service

“sudo systemctl enable NetworkManager.service”

  1. Disabled systemd-networkd services

“sudo systemctl disable systemd-networkd.service
sudo systemctl disable systemd-resolved.service”

  1. Rebooted and got a working internet. Then I could reinstall all the missing packages (reinstalled Plasma).

What to learn from this? Do not uninstall GNOME using “-Rncs” or whatever the hell the command was that borked everything. :smiley:

Please try to refrain from cursing :hugs:

1 Like

Combing -Rc and -Rs is fairly dangerous. This will recursively remove dependencies so it will even remove optional dependencies(and everything that depends on those optional dependencies). When you use that you need to extra careful about reading the package list that is about to be removed. On the other hand, if you are removing a desktop you might want to be fairly aggressive in getting rid of the extra stuff so it is all a balance.

1 Like

Cursing is the sign of honest expression, so no promises. :smiley:

Yes, I wanted to remove Budgie, GNOME and pretty much anything related to them. Mainly to save some space on the root partition. It fills up pretty quick with 3 DEs installed. I couldn’t uninstall them without “that” command.

Luckily it was pretty easy to backtrace what went wrong and reinstall the network manager.

I noticed that I had to add my download client to the firewall allowed list. Everything else has worked flawlessly so far.