Missing media controller shortcuts

Hi all, I recently installed Endeavour OS with KDE Plasma, the problem is that the media controller shortcuts are missing.
How can I do to add them to the system?
Thank you.

Is that a screenshot of your system settings? If so click on the Media Controller and set the shortcuts to something else and see if that works.

No, it is a picture taken from the internet, my intent was to show what is missing.

Ok, you may be missing kdeplasma-addons I think

Just tried, kdeplasma-addons is already installed, I tried reinstalling it but nothing.

Hmm, not too sure then. I have it available on my system but unsure if they where there when I did a fresh install or if they came as part of a dependency of something as I don’t use the shortcuts for it.

Can you tell me what it says in the part about media controls in the ~/.config/kglobalshortcutsrc file?
So that I can put them in my file as well and see if it works.
I am only interested in play/pause, previous and next.

_k_friendly_name=Media Controller
mediavolumedown=none,,Media volume down
mediavolumeup=none,,Media volume up
nextmedia=Media Next,Media Next,Media playback next
pausemedia=Media Pause,Media Pause,Pause media playback
playmedia=none,,Play media playback
playpausemedia=Media Play,Media Play,Play/Pause media playback
previousmedia=Media Previous,Media Previous,Media playback previous
stopmedia=Media Stop,Media Stop,Stop media playback

I think this it what you where after. Hope you can get it working.

1 Like

Now the media controller item has appeared in the settings, but the shortcuts don’t work.

Have you tried changing the shortcuts? I just tried it out and had to change the shortcuts for them to work

Yes, Media playback next: F10, Media playback previous: F8, Play/Pause media playback: F9.

Not too sure what the issue could be then, I used meta+F6 for previous etc

Currently on plasma 6, but I just checked and I still see it in my system settings.

Just upgraded to Plasma 6 and now it works.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.