Missing ESP Flag

Hello, Endeavoursmates :wink:

Unfortunately Ik spreek geen Nederlands, thus let’s start up the English Mode :wink:
I installed EndeavourOS with NO difficulties in a BIOS-MBR 64bit laptop, but I’d like to install it in a GPT-EFI, however the Calamares insists to tell me that is missing the ESP flag and I really can’t find this ESP flag at all! I only see the bios-grub and the boot flags.
Which one should I check off?
I’ve been checked off the boot one, but this option generates an error and I won’t check the bios-grub off because I think that this is for BIOS-MBR computers.

Best regards, guys.

if you start the iso of uefi you startoff in a systemd-boot screen, if you start in grub or what it looks like then is something not set.

general it installes in /boot/efi , and endeavour does use grub there is no gpt-grub flag

1 Like

Hello, @ringo.

Thank you for answering me so quick.

Yes, I started it in UEFI mode. Actually I was trying to test Endeavour OS on a computer that already has other OS installed, Manjaro, and my partitions are sda1 (efi-fat32 type on path: /boot/efi) and sd2 (the Manjaro itself) and other empty partition, sda3, which I wanted to install Endeavour to test it.

Lemme explain you that, in Endeavour installation, I mark the sda1 as the boot partition.
Also consider, please, that I am not a noob about Linux installations, I know what I’m doing, the problem is that Endeavour does not has the esp flag and even I mark the boot flag, an error is generated.

I just came up with an idea. Before starting Calamares, I will open a terminal and try to set up all the partitions via gdisk.

Welcome @NewKommerInLinux to EndeavourOS,

the answer is already given on the site :

Manual partition on EFI systems
When creating the fat32 partition for boot, you’ll notice that the flag ‘esp’ isn’t in the options anymore, you can choose the flag ‘boot’ instead.
To avoid problems, you can make a partition scheme by using Gparted before you start Calamares. When you have set the partitions and flags, you can start up Calamares and choose manual installation. We recommend this with all installation schemes, by the way.

https://endeavouros.com/docs/installation/calamares-offline-installer-tips/#manual-partition-on-efi-systems

Otherwise, check your Bios and be sure that :

  • Boot Mode Select is on UEFI or LEGACY + UEFI
    (About LEGACY + UEFI sometimes some problems appears depending your motherboard and Bios version, an update only if necessary).
  • Your HDD is selected on UEFI Hard Drive Priorities

You will have to see UEFI OS for instal after it.

The Endeavor Greeter Windows is very useful, I remember to find this answer from it.

3 Likes

you can always by gparted for your partioning especially for the flags

Thank you @FLVAL.

I used Gparted in the first attempt-failed-installation and made the partitions there. As a result, as you can suppose, error.
So I tried only thru Calamares, as a result, the same error.
As I read your post, I decided redo the installation using Gparted and see in which point I neglected.
Guess what? The solution is simple!
In Gparted, I only had to change the flag information of sda1, which is the /boot/efi partition, with no need of formatting it.
I must say I did NOT make that before. This turn I just had to point the partition, open a pop-up window and click on the flag option and do the adjustments required choosing the right flags: esp and boot.

Thanks, @FLVAL and Thanks to all community.

Atually, I’m using Endeavour right now to post :wink:

1 Like

Great @NewKommerInLinux, :wink:

As told the Calamares Offline Installer Tips on the site and @JR29, create HDD partition scheme with flags on GPARTED from Live EndeavourOS is the key. I put here an exemple of partition scheme with flags from Gparted, for those who need it.

  • Recommandation from the site here to not make SWAP on SSD
3 Likes