-> Missing AUR Packages: yad-eos

I got this message, an the package is only installed locally.

Is this package now obsolete for eos? Replaced? Can I only uninstall it?


Aur? yad-eos is in endeavouros’s repo. What distro are you using?

$ pacman -Ss yad-eos
endeavouros/yad-eos 12.1-1.1 [installed]
    A fork of zenity - display graphical dialogs from shell scripts or command line

There are other packages with similar names in the AUR though, and another yad in the community repo.

$ yay -Ss yad
aur/yad-git 9267829-1 (+1 0.00)
    A fork of zenity - display graphical dialogs from shell scripts or command line
community/yad 12.1-1 (209.3 KiB 613.4 KiB)
    A fork of zenity - display graphical dialogs from shell scripts or command line

You can uninstall it if no other packages depend on it. AFAIK, a package called eos-bash-shared requires it.

1 Like

I’m on eos with endeavouros repo enabled but that package is missing there

edit: just did a -Syu an it seems to be back. So problem solved.


1 Like

I also got that message when was updating. -Syu didn’t helped but after I ranked mirrors update went normally.

Package yad-eos was removed today from our repo, and now the official yad from Arch can/should be used.
Sorry about the above.

yad-eos was updated today. But now yad-eos can be replaced with the yad package from Arch.


eos-bash-shared still requires yad-eos and eos-bash-shared is required from other EOS tools. Can those tools be removed without loosing necessary features?

You can use pactree to list out all the packages that depend on yad-eos.

$ pactree -r yad-eos

Personally, I would keep the eos tools.

Yes but they all run with yad? :thinking:

eos-bash-shared is a requirement by many EndeavourOS packages.
So if you want to remove eos-bash-shared, then you will lose many EndeavourOS packages, like (in alphabetical order)

  • akm
  • eos-apps-info
  • eos-log-tool
  • eos-rankmirrors
  • eos-update-notifier
  • reflector-simple
  • welcome

However, Arch packages are not affected.

I must have misunderstood @kiamlaluno’s question. Because he asked about yad-eos, so I’m assuming that he hasn’t yet run the latest upgrade? Because if he had, yad-eos would have been replaced by yad already.

As of right now, yad-eos is still in the EndeavourOS x86_64 package repository.

Also as of right now, The endeavouros repository is listed first in /etc/pacman.conf

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

#Include = /etc/pacman.d/mirrorlist

So the only way an update could replace yad-eos with yad would be with a statement in the PKGBUILD stating yad-eos and yad are conflicting.

I am not sure what the following lines un the PKGBUILD do, but I don’t think this replaces yad-eos with yad. @manuel would have yo answer this.

    # Take care of conflicting packages:
    conflicts=($orig_name ${orig_name}-git)



Yeah, there have been a couple of changes today related to yad and yad-eos. The plan is to override the yad package from Arch to make it simpler to use than having a package yad-eos.

The idea with an overridden package is to add a patch into yad to handle an issue of adding unnecessary height to windows implemented using the yad tool. And the plan is to remove the overriding package if/when the yad devs add a fix to this issue.

The following shows the line (45) that replaces yad-eos with endeavouros/yad:

You may see that the patch is not included in this package version. It seems there’s no need for the patch anymore, but I will keep the overriding yad version just in case more testing shows that the issue still exists.

So please keep reporting if you still see unnecessarily high yad windows with any of the EndeavourOS apps (that use yad).


Earlier today I did an -Syu update and it didn’t list anything about yad-eos or yad and yad-eos was still installed.

I just did another -Syu update and it did replace yad-eos with yad.

:: Starting full system upgrade...
:: Replace yad-eos with endeavouros/yad? [Y/n] y
resolving dependencies...

Please excuse me that I was little behind on what was going on.


No worries mate! Seems that for some reason your link to PKGBUILD is about 4 hours older than mine… which explains the code difference, but not why it is so much older. :sweat_smile:

1 Like

It takes a little while for the Pony Express to get to Colorado. Except today it is Comcast instead of the Pony Express, but the results are about the same.


1 Like

I apologize: I was referring to this sentence.

yad-eos was updated today. But now yad-eos can be replaced with the yad package from Arch.

There are EOS tools that require yad-eos; if I replace it with yad, I should remove them. That’s why I asked if removing those tools I lose “important” functionality.

I updated earlier, but yad-eos wasn’t replaced. I ran yay -Syu now, and it got replaced. (I didn’t see any EOS tools being removed, though.)

Yes, latest endeavouros/yad is meant to replace yad-eos.

The endeavouros mirrors get the latest packages at different times, which is how mirrors work, and that’s why users get the latest packages at different times.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.