Missing a screenshot tool

I was wondering if there is a recommended screenshot tool that works with the default budgie key bindings. I tried gnome-screenshot but CTRL+printscreen doesn’t seem to work on it, which is supposed to let you do a selection of what is on the desktop.

Thanks

xfce4-screenshooter, spectacle

1 Like

scrot is another option. You can even record your screen with it and then save it as either a gif file or mp4.

1 Like

I tried scrot but it didn’t work with budgies default screenshot commands.

Spectacle has too many dependencies for me to want to install on budgie. xfce4-screenshooter installs a bunch of xfce stuff that I don’t want on my budgie install like the xfce panel as an example.

I found that gnome screenshot worked the best but for screen selection you have to hold the key combination for like 2-3 seconds before it activated.

Do you mean you can’t use the default keybindings to launch it, or…? Because if that’s the case, you could customize the keybindings.

As in you have to hold down the key combo for the GUI to launch?

I didn’t have a screenshot tool out of the box on budgie but the key binding already existed. So I had to install one but didn’t know which one to use. Since this is on Mutter/Gnome I was guessing gnome-screenshot but wasn’t 100% sure.

Screenshot from 2022-11-10 22-32-17

Yes that is correct for the “Save a screenshot of an area to Pictures” option I have to hold the key combination (Default Ctrl+Print) for like 2 to 3 seconds (almost like a long press) for it to activate. If I just hit the key combo quickly it does nothing, but the other two options work fine just pressing them.

That is certainly strange… What if you change the default binding (Shift+Print) to something else? Is there still a delay?

1 Like

Yeah I have it changed to “Shift + Print” from “Ctrl + Print” and it still does the same thing. I’m using gnome-screenshot 41.0, if there is a different version or I should be using something else let me know.

Maybe try to configure the settings of gnome-screenshot? It just seems weird for there to be a 3-second delay before a keybinding takes effect.

There aren’t any configurations on the screenshot that are crazy since it’s a bare bones option. But you did make me think and I went back and changed the settings to just be something without the Print key and it works much faster.

So it might be my old laptop keyboard causing problems or the way budgies reads the keys and it is sometimes seeing the initiator key by itself or taking a while to see that they are both pressed. But ALT + Print works super quick. So I’m just going to leave the screenshot selection option to be Ctrl+/.

1 Like

Glad to hear you managed to find a better way. If you are interested to investigate further, you could install a tool called xev to check if there is any delay in keypress events (for the Print key). The xev utility program is part of the package xorg-xev if I’m not mistaken.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.