Migrating from grub to rEFInd. Snapshots and other things

So I set up Timeshift as per the EOS Wiki page, and not only does it work, it really saved my but during a grub config screwup. Since then I’ve installed rEFInd, which I also like, but I don’t see any Timeshift snapshot integration. On the other hand, the Arch wiki has it integrating well with Snapper and BTRFS-Assistant. I suppose it’s not beyond the realm to change over, but I’m wondering if anyone else knew something about tying rEFInd and Timeshift together that Google doesn’t before I start doing the switchover.

1 Like

What about using timeshift-autosnap. It runs before package upgrade with pacman hook.

Edit: Not sure how you are using rEFInd? Are you booting from grub64xefi or the vmlinuz-linux image? Shouldn’t make any difference whether using Timeshift with autosnap or btrfs and btrfs-assistant with snapper and snap-pac. That is what i used previously but now i have switched to systemd-boot with btrfs and btfs-assistant, snapper and snap-pac.

1 Like

I have tried everything mentioned here.
I can say this quoted configuration is absolutely the best (my personal experience).

I just did it again.
I was on BTRFS but just now I converted again to systemd-boot as per instructions of @dalto at [Tutorial] Convert to systemd-boot

I followed the steps I did before exactly at my post there.

Everything working perfectly.

I just installed rEFInd and can boot from it direct to the vmlinuz-image (actually vmlinuz-zen), though I’m not happy with how the icons and boot options are listed (can’t get manual stanzas working right yet either, still working on those, but if I could just get it to use an EOS icon for Zen and LTS and Tux for the grub menu I’d be happy). I’ve still got grub in there if I want to boot to an exisitng timeshift snapshot, but I’d like to integrate better with rEFInd directly and only use grub if something goes wrong with rEFInd. Obviously I’ll start a new thread on those issues if I don’t get anywhere. :wink:

From what I’m reading snapper is a much more universally compatible option, which I wish I’d known when i set up snapshots using the Timeshift discovery article. Looks reasonable enough to swap out though, as long as I include btrfs-assistant I’ll have the same functionality. More even, but it does require that GUI component to be installed seperately to get the automatic/prompted restore going. I did want to pick a few brains before getting too crazy though.

There are quite a few options in the config on that. You probably are going to want to disable folding for example. When you use folding on Arch the more recently installed kernel is the one used which is probably not what you want. If you disable that, it will show your kernels separately.

snapper has far more functionality than timeshift as it relates to btrfs snapshots. Timeshift’s btrfs snapshot functionality is exceptionally limited.

If you want to get notified when you are booting off a snapshot, you can try snapper-snapshot-notification-git from AUR.

Looks like I already installed btrfs-snapshot-notification-git, looks like they do pretty much the same thing though. Same maintainer even. :slight_smile:

Wow, almost missed that scrolling through the config…it’s well documented (much better than grub) but…extensive. I’m going to have to find some time later to read the whole thing in detail. So far I only found the manual stanzas and the resolution settings (helpful for larger text though the lowest widescreen option is 720p).

I’m going to change the thread title to overall reflect the larger project of cutting over to rEFInd just so I’m not getting OT in my own thread. :slight_smile: I do see some advantages to this though, the configs are pretty clear compared to grub.

1 Like

When you install rEFInd initially it will show two icons. One is grubx64.efi and the other is the vmlinuz-linux image. All you have to do is download an icon in .png format. Then rename it os_xxxxxx.png where x is the folder name that has the grubx64.efi file. Then you copy this file in the rEFInd icon folder. So for grub if you wanted to keep tux you don’t need to do anything except hide the other icon using the delete key. For the vmlinuz image file you do the same but you copy it into the folder that has the vmlinuz-linux image. So if it is zen or lts you need to have both named appropriately. So the icon name would be vmlinuz-linux-zen and or vmlinux-linx-lts. For current kernel it would be vmlinuz-linux. Copy them to the folder that has the vmlinuz-linux image file. Then your icons in rEFInd will be what you want. Hide the other grubx64.efi icons you don’t want if you are booting from the vmlinuz-linux image file. That’s it! I don’t do any fancy configuring of any conf file. It’s not necessary unless you have something specific needed.

With btrfs and snapper i also don’t have anything fancy. I don’t care about booting to a snapshot. So i just have btrfs-assistant, snapper and snap-pac. That’s it. Depends on what you want or what you need.

1 Like

Awesome. Here, someone might find these useful, they’re just quickies but I like how they came out.


Hope it works for you the way i explained it.

Edit: I’m no expert btw that’s @dalto :laughing:

If you look in Discovery for “installing rEFInd”, the icon display choices are explained in there, and visual examples provided… :grin:

(wiki article author)

Ask if any troubles…

1 Like

Where have you been my Canadian friend? Everyone has been on the rEFInd train since this grub saga! Well…not everyone but a number of users. :wink:

Just fighting Internet outages and power outages too. Such old fashioned infrastructure we have here - just let one over-exuberant garbage truck driver drive ahead with the bin still on maximum height, and wires and poles are stretched to the limit!

Did you know I had a little trouble with grub too? When updating my mirror server, I was also doing other things, and forgot to do a grub-install! Then I couldn’t even get an arch-chroot to go…forgot I had a separate /boot (because of running XFS) and didn’t mount it the first time… (ulp)

Fun is where you find it!

I hear you. I actually was using rEFInd and was triple booting using the grubx64.efi. So i ran into the issue also although it was an easy fix i wasn’t satisfied with grub and it was doing strange things in UEFI. So i switched for now to systemd-boot. I think i may end up back with rEFInd but i will use the vmlinuz-linux image files this time around. Not sure though as i do also like systemd-boot. but i don’t know much about it. Got it working thanks to the tutorial.

Didn’t realize there was a tutorial in Discover, going to spend some time with that too. Not to step on the timeshift article, but given the times maybe an option that’s a little more universal is called for. And something a little more howto than the Arch Wiki page on the subject (which is pretty good as a reference but not so much as a howto).

Ok that didn’t work at all, everything is still just the generic Tux it uses for everything by default. Did you mean that the filenames should be os_vmlinuz-linux-zen.png or just vmlinuz-linux.zen.png?

EDIT, it’s without your m the os_ prefix. Getting there!


No. I thought I explained it right? If you are going to boot from the vmlinuz-linux image then the icon.png has to be named vmlinuz-linux and copied in the same location as the file. That is for the current kernel as that is how it’s named. If it’s the zen then it is vmlinuz-linux-zen and so on. If you are booting from the grubx64.efi file then it has to be named os_xxxx.png to match the name of the folder that the grubx64.efi file is in and copied to the refind icon folder. It’s all explained in the wiki. But my explanation should be the same.

Yeah, I thought you meant to add the os_ part initially on all of them. That’s on me. ANd in my excitement I haven’t read the wiki page yet. I did get it to where I like it, except for snapshot detection but I was missing a couple of componenets. TImeshift is definitely easier to set up, but snapper seems much more flexible. That’s generally how it goes.

Very close here. I just have to get the snapper snapshots to show up. They exist so that isn’t an issue at least. I must be missing something somewhere but I’ll find it sooner or later

EDIT: and I spoke too soon, broke something trying to get snapshots to detect. Good thing I kept grub around. :slight_smile:

I’m not sure about the snapper snapshots. I never did that on mine. Well I did try it with grub but decided I didn’t want it. Then I moved to rEFInd.

They’re actually working on grub…I can see them and boot to them. Not seeing them on rEFInd but I’m not sure I’m scanning the right location for them either. I’ve got @, @/.snapshots, @cache, @home, and @log, and BTRFS-Assistant has snapper storing it’s snapshots in @/.snapshots . I added @ and @/.snapshots to alsoscandirs in refind.conf, near as I can tell that should do the trick. I think.