Microsoft Teams, Just a Blank, White Window when Starting

For whatever reason, I need Microsoft Teams running, but after installing I just see a blank, white window when I launch it.

Tried to run it from terminal, but it doesn’t output anything.

Any pointers as to what I can try?:wink:

Hello.
Have you tried the flatpak version?
I think the AUR version needs some spells to work. :slight_smile:

Teams is now **not compatible with glibc 2.35** . It is upstream problem (aka Microsoft has to fix it/update). Here are the workarounds, which can be unstable or insecure.
AUR

See comments on AUR page:

https://aur.archlinux.org/packages/teams#comment-853957

There’s an incompatibility with its sandbox of the old electron release they use and the glibc update to 2.35. Try running it with the --no-sandbox argument in terminal → teams --no-sandbox. If this works then you can follow the below steps to fix the issue:

mkdir -p "${XDG_DATA_HOME:-$HOME/.local/share}/applications"
cp -a "/usr/share/applications/teams.desktop" "${XDG_DATA_HOME:-$HOME/.local/share}/applications/teams.desktop"
sed -i -e 's,teams %U,teams --no-sandbox %U,' "${XDG_DATA_HOME:-$HOME/.local/share}/applications/teams.desktop"

Now you should be able to launch teams as usual. In case you have Teams to start automatically at startup you must also run this:

sed -i -e 's,teams %U,teams --no-sandbox %U,' "${XDG_CONFIG_HOME:-$HOME/.config}/autostart/teams.desktop"
1 Like

Does the browser version work?

Hello, just use the flatpak version of Teams (https://flathub.org/apps/details/com.microsoft.Teams), works well. I too use Teams and never got the AUR version working well for some reason