Microphone (RODE NT-USB Mini) not recognized anywhere

Hey guys,
I have recently installed Edeavour on an old laptop because I am thinking about switching from windows to linux.
After installing Discord, I wanted to hop on a call with a friend, but noticed my mic wouldn’t show up as an input device. Later, I asked some friends that use linux, including the guy that recommended me Endevaour, if they know a fix. He advised me to download Easy effects to check if my mic shows up there, which wasn’t the case. Simple attempts at fixing my problem like unplugging the microphone and pluging it back in or restarting the laptop didn’t help.

What’s weird is that:

  1. the LED in the front of the the mic is on, which means the microphone is properly connected.

  2. The the headphone jack built into the mic is being recognised as an output device.
    image

Also my microphone works without any issues on my windows device.

Would love to hear from yall!

Welcome @smint! :wave: :sunglasses: :enos_flag:

While the mic is plugged in, can you run the following to generate a list of detected audio and USB devices, and share the output with us.

inxi -AJxx

Thank you :grin: Here you go:

Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:a170
  Device-2: RODE Microphones RØDE NT-USB Mini
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 bus-ID: 1-1:9 chip-ID: 19f7:0015
  API: ALSA v: k6.9.3-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
USB:
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s lanes: 1 chip-ID: 1d6b:0002
  Device-1: 1-1:9 info: RODE Microphones RØDE NT-USB Mini type: audio,HID
    driver: hid-generic,snd-usb-audio,usbhid rev: 2.0 speed: 12 Mb/s lanes: 1
    chip-ID: 19f7:0015
  Device-2: 1-2:8 info: Corsair M65 RGB ELITE Gaming Mouse type: mouse,HID
    driver: hid-generic,usbhid rev: 2.0 speed: 12 Mb/s lanes: 1
    chip-ID: 1b1c:1b5a
  Device-3: 1-5:4 info: Razer USA BlackWidow Elite type: keyboard,mouse
    driver: hid-generic,usbhid rev: 2.0 speed: 12 Mb/s lanes: 1
    chip-ID: 1532:0228
  Device-4: 1-7:5 info: Lite-On type: bluetooth driver: btusb rev: 2.0
    speed: 12 Mb/s lanes: 1 chip-ID: 04ca:3016
  Device-5: 1-9:6 info: Chicony HD WebCam type: video driver: uvcvideo
    rev: 2.0 speed: 480 Mb/s lanes: 1 chip-ID: 04f2:b520
  Device-6: 1-10:7 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc rev: 2.0
    speed: 480 Mb/s lanes: 1 chip-ID: 0bda:0129
  Hub-2: 2-0:1 info: super-speed hub ports: 8 rev: 3.0 speed: 5 Gb/s
    lanes: 1 chip-ID: 1d6b:0003

(sorry reviewing my response, I believe I made an error)

Sorry about that, I did make an error and I’ve now tested it here to make sure this is correct. You might be able to do this easily within your desktop environment’s settings (KDE, Gnome, etc), but I offer the command line here as a universal option.

To list recognised audio input sources:
pactl list short sources | grep input

Hopefully your Rode is listed there in some form (let us know if it isn’t, and share the output). Something similarish to this:

123     alsa_input.usb-RODE_Microphones_RODE.__NT-USB-00.iec958-stereo 
PipeWire        s16le 2ch 48000Hz       SUSPENDED
456     alsa_input.pci-0000_0c_00.4.analog-stereo       PipeWire        s32le 2ch 48000Hz       SUSPENDED

You can then set the default input device by copying it’s name and using it in this command (I expect the name of yours will not exactly match this, as this was just a guess!):

pactl set-default-source alsa_input.usb-RODE_Microphones_RODE.__NT-USB-00.iec958-stereo

No problem! This is all i got from getting my recognised input sources:

49      alsa_input.pci-0000_00_1f.3.analog-stereo       PipeWire        s32le 2ch 48000Hz       

Just some low hanging fruit to try, a different USB port perhaps? A different type ideally (if I’m not mistaken, you have it plugged into a USB 2.0 port at the moment, but your system appears to also have USB 3.0 ports).

I tried all the USB ports, it still didn’t help :confused: I have even tried a USB-C port with an adapter.

Reports of people successfully using this microphone under Linux / Arch, have been pretty solid. Obviously, that doesn’t help you currently.

I’m out of ideas, but there’s still a few things mentioned here you might try?
https://bbs.archlinux.org/viewtopic.php?id=272799

I’ll check it out, still thanks a ton for trying to help me! :handshake:

Update: It was an issue with the USB-Ports (or maybe their drivers). I am on a newer Laptop and my microphone works without issues there.