Micron NVMe M.2 SSD Overheating on Linux


Recently I bought a Lenovo IdeaPad Gaming 3 15ACH6 laptop. Specs are

  • Ryzen 5 5600H, RTX 3060 and 32GB RAM
  • 512GB Micron (MTFDHBA512TDV-1AZ1AABHA) on 1st slot
  • 2TB Kingston (KINGSTON SKC2500M82000G) on 2nd slot

I installed Windows 11 on Kingston and EndeavourOS on Micron one.

The problem is when I switch to EndeavourOS, Micron SSD starts to heat up immediately. Firstly I installed EndeavourOS with Plasma & BTRFS. Then later I cloned AOSP ROM source (about 140GB) and closed my computer. Next days I felt the heat under my hand, looked at temperatures with sensors and saw the Micron SSD cranks up to 100 - 110 °C. Checked the processes, found out baloo index reads the SSD with > 1GB/s and immediately disabled it.

Now it starts with 35 - 40 °C and goes up to 70 - 110 °C depending on my usage (few Chromium tabs and Telegram Desktop). Windows doesn’t have this problem, both SSDs stay between 35 - 40 °C as they should.

I also tried to run different distros without installing with my Ventoy LiveUSB. The Micron SSD’s temperature starts at 35 °C but every time I run sensors command, it starts heating and when I release it returns to normal. If I run sensors command at every 1 second (watch -n 1 sensors) it goes up to 45 - 50 °C max, but if I run it at every 0.1 second (watch -n 0.1 sensors) it goes up to 60 - 70 °C and more very quickly. Kingston SSD stays at 30 °C, unlike Micron.
Later I disabled SDDM, logged in with TTY and got similar results.

At this point I have no idea if it’s problem of the SSD, the incomplete ACPI table (not sure if it is) or anything else. I saw some people using this laptop and this SSD (https://linux-hardware.org/?id=nvme:micron-mtfdhba512tdv-1az1aabha) with Linux but never saw any post mentioning about such a problem.

As far as I know APST is enabled for this SSD:

$ sudo nvme get-feature /dev/nvme0 -f 0x0c -H
get-feature:0x0c (Autonomous Power State Transition), Current value:0x00000001 Autonomous Power State Transition Enable (APSTE): Enabled

And looks like PCIe ASPM is supported too:

$ journalctl -b | grep ASPM
Jul 29 02:57:16 endeavour kernel: acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]


could be also the drive itself is defective ?
Also it does not cause the issue on windows… you said windows is installed onto the other drive…

what does health checks say?

both ssds are in a good condition and i mentioned about windows (mounting only kingston ssd and later mounting both ssds after ditching linux) because liveusb boot (without mounting) and linux installation on my ssd (mounting only micron ssd) gives similar temperature results for both ssds

high r/w heats up ssd (baloo)
reading temperature repeatedly also heats up ssd (sensors and nvme-cli)

is the heating up also independent from used kernels? i mean LTS compared to latest p.e.
You can also try firmware package git version:

Yes. I tried both LTS and normal kernel then booted several distros with different kernels like Debian, Fedora and Ubuntu.