Meta key at random times not working, regardless whether on X or Wayland

I recently started having weird issues with the Meta (a.k.a. Win) key on EndeavourOS on Slimbook Pro X 14.


At seemingly random occasions, the Meta key stops working completely.

One minute, everything works fine and the Meta key works both to open up the application menu, Meta+Tab switches between Activities, Meta+W triggers the overview etc. etc.

The next, none of these do anymore.

Potential culprits (or what I tried to blame so far)

I initially blamed this on Lutris or Steam, but since then it happened a few times even without either running.

Then I thought it may be an issue Wayland, so I switched back to X11.

The problem persisted. I used xev and when the Meta key stops working in Plasma, also xev does not detect presses or releases of that button.

I have not yet figured out what triggers the problem …will update here, if I do.

Still, this is very annoying and any help would be greatly appreciated.


Sometimes – but not always – when I suspend to RAM (sleep) and then wake up the laptop again, Meta key would start working again.

Sometimes it takes a few sleep-wake-up cycles for that to happen though.

Where it worked

This is a new (about a week old) machine and when I ran the stock Ubuntu with GNOME set-up on it for the first few days, this issue did not show up. (I’m not 100% dismissing a HW issue, but this seems like relevant info.)

(I am posting this to Plasma, but feel free to move wherever it fits better.)

Regardless of compositor xev/wev (wev is xev on wayland) should detect the key. My guess is hardware.

If you boot off the install media into a live system, does it work??

1 Like

I have not tried that yet, and as I said, it seems to kick off at random, so I hard to tell how long I would need to use it test it properly :person_shrugging:

Is there a way to detect it in the console / tty?

In a terminal:

 xev -event keyboard

It will report keytstrokes made in the terminal, without all the noise from the touchpad.

That only works in a terminal emulator.

What I’m asking is if it is possible to detect this as a faulty button without windowing system – without X and without Wayland?

At work, so sneakin’ a peek at the forum and read it wrong! Not that I know of.

I remember having a problem with the Super key with Plasma 4 and having to use (from memory) Ksuperkey.

Yeah, but the KSuperKey thing was likely the issue from a few years ago (in Plasma) when Meta would only act as a modifier, but did not want to open the menu.

In any case I’ll write to Slimbook to ask them what they think. This laptop has a custom Meta key engraving, so it may actually be an issue with the hardware, let’s see …

(Don’t get into trouble at work on my behalf!)

Many keyboards have a meta key “lock” feature, which intentionally disables the key. I believe it is for Windows users, to prevent disrupting a game by accidentally pressing it.

See if you can figure out if your keyboard has it, and how to trigger it (sometimes it is Fn + meta, not always). Maybe it is being triggered inadvertently.

1 Like

That was in fact it. I just got an answer from Slimbook’s support saying that Fn+F2 is hard-coded to disable/enable the Meta key.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.