Messing with Base-devel + Common packages to get more minimal install

Hi guys! I’m sure this is a stupid/noob question and I’m sorry but anyway…

I’m reinstalling eOS to try and make it more “minimal” or as bare bones as possible by cutting down useless (to me) packages in Base-devel + Common packages.

I’m guessing I could deselect stuff for hardware I’m not using like AMD/ATI drivers and EFIbootmgr. What else can I deselect?

Thanks in advance!

If you want a truly “bare bones” installation then you should start from an Arch installation and build up from there (e.g. add the EnOS repos and packages you want). :wink:

1 Like

You can remove everything in common except efibootmgr if you are doing a UEFI install.

I have done base installs by not checking anything at all except that and you get a working CLI system out of the box.

1 Like

Hey thanks for the reply! Wasn’t expecting one that fast.

Anyway, I’ve already gone that route multiple times.

  • Tried to install Arch the normal way multiple times but ends up freezing at Grub boot every time
  • Archfi script also ends up freezing at Grub boot every time
  • Anarchy installer worked but turns out it uses an unsigned repo (read this from an old reddit post that was posted 3 years ago) so I don’t really trust it
  • ArcoLinux also freezes at Grub boot (just tried this tonight)
  • Haven’t tried Calam Arch installer but that already looks a bit sketchy

eOS is the only “basically pure Arch” Arch based distro that I’ve been able to install and use.
So if I can’t get it to work the way I want I don’t know where to go other than back to Manjaro or Windows…

I have a legacy system. So I can also deselect efibootmgr too right?

In that case, I believe you could probably literally select nothing. To be fair, I haven’t tested that because I haven’t done a legacy install in a long time.


Just tired that and everything works! I checked literally nothing except plasma and got a really minimal install. Package count is at 580, RAM usage at 450MB booted into Plasma 5.21. By far the lowest I’ve seen ever.

It’s so minimal neofetch shows distro and logo as Arch instead of eOS lmao.

I couldn’t have asked for better. Thank you so much!


You could install eos-hooks which will bring in the some EOS related pacman hooks. That will fix the neofetch logo.

Just as another tip, you can give thanks by marking as a Solution the post that gave you the answer (or at least the pointer towards the answer), e.g. Messing with Base-devel + Common packages to get more minimal install - #6 by dalto . In my experience it’s a little bit more polite to do that than marking your own “concluding” post as the solution.


I was on my phone and there were only mark as Solution buttons on for my replies for some reason.

Just corrected it. Thanks for the heads up and sorry!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.