Mesa 21.x Missing R300 Gallium Drivers

I have a Radeon X1000-series R300 graphics card in an elderly laptop. Tried Manjaro, no R300 driver. Tried Endeavour, again no R300.

(I built Mesa with R300: then it worked fine - so it’s something not baked into the driver rather than something w/my GPU)

Thus I would like to report that the Mesa driver is not being built with R300 support. Expected behavior is for R300 cards to function out of the box.


Thank you!

There’s nothing EnOS can do here as the packages come from Arch.

I’m not sure that supporting a 20-year-old GPU is something they would consider, either… :thinking:

i guess you need the mesa-amber and lib32-mesa-amber packages for your ancient hardware.

That split was made upstream to get rid of the old stuff in mesa in order to make development and maintenance of the current drivers easier.

1 Like


Welcome to the EndeavourOS forum. I hope you enjoy your time here.


Not sure… archwiki shows r300 should be in the default mesa package…

There are two Mesa packages each with a distinct set of drivers:
  • mesa is the up to date Mesa package which includes most of the modern drivers for newer hardware:

    • r300 : for AMD’s Radeon R300, R400, and R500 GPUs.
    • r600 : for AMD’s Radeon R600 GPUs up to Northern Islands. Officially supported by AMD.
    • radeonsi : for AMD’s Southern Island GPUs and later. Officially supported by AMD.
    • nouveau : Nouveau is the open-source driver for NVIDIA GPUs.
    • virtio_gpu : a virtual GPU driver for virtio, can be used with QEMU based VMMs (like KVM or Xen).
    • vmwgfx : for VMware virtual GPUs.
    • crocus : for Intel’s Gen 4 to Gen 7 hardware.
    • iris : for Intel’s Gen 8 hardware and later. Officially supported by Intel.
    • zink : a Gallium driver used to run OpenGL on top of Vulkan.
    • d3d12 : for OpenGL 3.3 support on devices that only support D3D12 (i.e. WSL).
    • swrast : a legacy software rasterizer.
    • softpipe : a software rasterizer and a reference Gallium driver.
    • llvmpipe : a software rasterizer which uses LLVM for x86 JIT code generation and is multi-threaded.
  • mesa-amber is the legacy Mesa package which includes the classic (non-Gallium3D) drivers for older hardware:

    • i830 and i915 : for older Intel integrated GPUs. Same binary as i965.
    • i965 : for Intel’s Gen 4 hardware and later. Officially supported by Intel.
    • radeon : for AMD’s Radeon R100 GPUs. Same binary as r200.
    • r200 : for AMD’s Radeon R200 GPUs.
    • nouveau_vieux : for NVIDIA NV04 (Fahrenheit) to NV20 (Kelvin) GPUs.
    • swrast : a legacy software rasterizer.

how do you do that? or what exactly is the needed -D option to enable build it with?

But as @jonathon mentioned this is not an EndeavourOS BUG also it may effect EndeavourOS because we do use arch packages directly… it is an upstream BUG on arch … moved to

and I see this in default mesa:

So it could be that the card needs indeed an older non-gallium driver?

you are right, the X1000 desktop series (engineering: r500, supported by driver r300) SHOULD still be supported by the regular mesa - packages
according to this site:
r300 already is a gallium-driver, too.

Would you mind posting the output of inxi -Gxxz on the machine?
I suspect that the mobile X1000 is not a real X1000 like on desktop, but an older chip, maybe only supported by r200 or r100. Unfortunately, using older chips for mobile and rebranding them to an officially more modern series is a common practice.