Memory Error with Ardour

I posted this on an older thread, but though maybe it makes more sense to start a new one.


So i’ve installed Jack and it seems to be running. I added permissions for it according to Unfa’s manjaro setup video. However, I get the following error when I start Ardour. Is there something I need to add to remove that error?

"WARNING: Your system has a limit for maximum amount of locked memory. This might cause Ardour to run out of memory before your system runs out of memory.

You can view the memory limit with ‘ulimit -l’, and it is normally controlled by /etc/security/limits.conf

How much ram do you have and what does ulimit -l show?

I have 16gb. Limit -l shows 1024

A quick web search shows that many Ardour users recommending changing it to unlimited

Do you know how I can change that? I’ve tried pretty much everything the link below, but I still have the same error.

I’m not an expert with ardour but I think first of all you need to be in the audio group. Enter groups in the terminal and see if audio is one of the groups the user is in.

Then you need to edit the the file /etc/security/limits.conf
Add the following at the bottom before the line # End of file

#audio group
@audio - rtprio 95
@audio - memlock unlimited

Hopefully this works for you.

Edit: Should look like this as i can’t seem to get it to space out properly here.


Thank you. Yes. I did that but I am still getting the error. I am in the audio group and have added those two lines.

Did you log out and back in or reboot?


Unlimited may not work as i have read on a number of websites. Maybe try something closer to your ram size? Try 12000 maybe. I’m just guessing.

Edit: Of course it could be something else entirely. I really don’t know what the issue is other than getting an error message.

I did log out and reset. I can try setting to a different number as you mentioned. I haven’t yet used the program much, so don’t know if this will cause any issues. I guess I will just leave it for now and come back once I have problems. Thank you very much for your help.