MEGAsync don't start

I have a problem with MEGAsync don’t starting at system boot. Even when I manually launch the app it don’t work. When i try to launch the app through terminal it gives me:
QSettings::value: Empty key passed
QSettings::value: Empty key passed

Following this guide, I deleted megasync.lock and I could finally launch the app. Closing and opening works till the next reboot.

Tested on all packages from AUR and official one from

Also wrote a crontab script for automatic

  1. deleting a megasync.lock
    and then
  2. starting an app

at system start
The file gets deleted but app isn’t launching.

PS When I installed the app first time, it all worked fine, so I think I broke something in the system.

Hello @gaucho and welcome to :enos: forum.

You are the first member I have come across who actually got Megasync working. even though as you said you broke it. Mega support technician told me it is not supported on Arch, but it seems I was misinformed since you had it working at one time.

Presently I only use the Mega browser extension, but would prefer to do it the way you had it. So hopefully some genius can chime in and help solve it, so we can all benefit. Have you seen this post on Mega?

Mega does not seem to be very popular here, but since I use it just as a secondary backup for syncing non-sensitive .md files from Obsidian, it’s not a real concern.

Mega is in the AUR

Could the flatpak version be something to consider?


Well, then I am probably the second one. I am using megasync since a while with no issue. It is starting automatically in gnome. And the nautilus plugin is working as well just fine.

nautilus-megasync 3.6.6-2
1 Like

I also use Mega, never got MegaSync to work. What does work is Rclone with Mega provider. Hasn’t failed yet since I switched from OneDrive.

1 Like

And I am the third. It runs fine since a year or so.

I am giving it another try now. Thanks @mbod

And I am the fourth. Been using it for years.

1 Like


Thanks @mbod it worked like a dream. Big installation process though.

@gaucho give this a try.

yay -S megasync
yay -S nautilus-megasync

All credit to @mbod who saved the day once again.

I almost gave up on them working together in Gnome. I will start a thread on another aspect of it.

1 Like

Sorry that I wasn’t replaying

I turned my pc a moment ago and I don’t get why everything worked. (the one thing i did differently was that i didn’t type my password instantly but after 2-3 mins), ofc after reboot don’t work

I was installing a megasync from AUR, basically all packages available there (but without file manager integration, i my case dolphin bc i am using Plasma), but i will try that again.

Later i will try flatpak version as @pebcak advised, if that won’t work.

Thanks everyone

1 Like

It would be helpful to other members if you mark the post that solved your problem :white_check_mark:

I will do that for sure, but right now none of this have worked.

What is the output when you tried the following

That’s the output, a LOT of warnings.
I am adding a file bc site is throwing 502 error
megainstall.odt (449.3 KB)

When I am deleting and adding mega to startup(with gnome-tweaks) it says that it’s launched, Task manager also proves that, so there is a problem with displaying the icon in system tray.

Next time you create a log file for this forum please switch your terminal language to english first.


should to the trick. Otherwise it is very hard to read.

Do you have this extension installed in GNOME:


Ok, will do that.

I am using Plasma primarily but have also Xfce installed and I am not using Gnome

That’s why I assumed you had GNOME.

Are you using gnome-tweaks on Plasma and/or Xfce?

1 Like