Megasync and fsearch do not start after the update

I have traditionally updated the system on my computer and my wife’s computer tonight.
After the update, megasync does not start on both computers and fsearch does not start on my computer either.
If you roll back to the state before the update, everything works. Reinstalling programs (uninstall-reboot-install) does not change anything.
What to do?

Normally AUR packages which depends on some other packages which are updated need to be rebuild.

I see that both megasync and fsearch are dependend on icu which got updated recently.

You could try cleanbuilding them and see if they will start working.

1 Like

Do I understand correctly that I need to clear the yay cache and reinstall it?

I guess you could clear the cache for the relevant packages if you want to keep it for the others.

Or, I believe you could pass --cleanmenu to yay.

So, fsearch was able to reinstall and run. Megasync still won’t start.

Could you run megasync from the terminal and see if it will give some output hinting to the issue?

[vladimir@vladimir-mini ~]$ megasync
megasync: error while loading shared libraries: libicuuc.so.74: cannot open shared object file
: No such file or directory

A problem with libicuuc.so.74?

Looks like megasync it is still referring the outdated library.

The current one is libicuuc.so.75.

Which AUR package are you using megasync or megasync-bin?

megasync
But I also tried installing it directly from the Mega website.

Then perhaps an upstream update to megasync package is what is needed? :thinking:

I’m not sure I understood what was written. Sorry :worried:

Have you tried yay -S megasync --rebuild? Then when it gets to packages to clean build hit ‘a’ then diffs ‘n’ and let it run. That way you are rebuilding megasync with the new libicuuc.so.75.

I mean, maybe the developers need to release a new version of megasync for Arch to take into account the new updated libraries.

You could also create an issue at the link below t let them know:

EDIT:

Try what @wordler suggested. From your previous output, it looks like that megasync is still building against the outdated icu package.

Just installs without asking questions

Спойлер
[vladimir@vladimir-mini ~]$ yay -S megasync --rebuild
Sync Explicit (1): megasync-5.2.1-4
предупреждение: megasync-5.2.1-4 не устарел -- переустанавливается
разрешение зависимостей...
проверка конфликтов...

Пакет (1)                Старая версия  Новая версия  Изменение размера

DEB_Arch_Extra/megasync  5.2.1-4        5.2.1-4                0,00 MiB

Будет установлено:  58,17 MiB
Изменение размера:   0,00 MiB

:: Приступить к установке? [Y/n] y
(1/1) проверка ключей                                    [------------------------------] 100%
(1/1) проверка целостности пакета                        [------------------------------] 100%
(1/1) загрузка файлов пакетов                            [------------------------------] 100%
(1/1) проверка конфликтов файлов                         [------------------------------] 100%
:: Запуск pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 789
:: Обработка изменений пакета...
(1/1) переустановка megasync                             [------------------------------] 100%
fs.inotify.max_user_watches = 524288
:: Запуск post-transaction hooks...
(1/5) Arming ConditionNeedsUpdate...
(2/5) Updating icon theme caches...
(3/5) Checking which packages need to be rebuilt
(4/5) Updating the desktop file MIME type cache...
(5/5) Performing snapper post snapshots for the following configurations...
==> root: 790

Hmm, that is weird! If it’s an AUR package it should rebuild. Oh, 5.2.1-4, that’s the megasync-bin. You need 5.2.1.0-1 to do a rebuild I think. Probably best to go into the yay cache in your home folder and remove megasync completely then download the second one in the AUR and run that command I gave you again.

1 Like

Looks like he is installing it from megasync’s repo:

@VlPo

You need to disable megasync’s repo in your /etc/pacman.conf.

Uninstall your current megasync.

Then clean the yay cache for megasync.

Now build the AUR package megasync:

yay -S megasync

1 Like

Exactly @pebcak , he needs to build through Arch. If you use external repos you invariably run into problems. I still think he will need to do a cleanbuild though.

1 Like

I’m not that fast :joy:
So, I have reached the installation stage. Which option should I choose now?

Спойлер
[vladimir@vladimir-mini ~]$ yay -S megasync
:: Существует 3 пакетов которые удволетворяют libpdfium
:: Репозиторий AUR
    1) libpdfium-nojs 2) pdfium-binaries 3) pdfium-binaries-v8 

Введите номер (по умолчанию = 1): 
==>

It is normally 1. and then use the ‘a’ option to cleanbuild.

A tips:

If you prefix a command with LANG=C the output will be in English.

Perhaps a bit more practical :slightly_smiling_face: