MCE lead to my system breaking after an upgrade

This my first post so if i am posting this in the wrong place or doing anything else wrong, pls let me know. So here is what happened, I got a PC assembled (i5 10400F, Gigabyte H410M S2 V3 rev 1.0 mobo, 8GB ram, nvidia gt 710 with the stock cooling that comes with the processor) and I tried installing endeavour through the online mode (plasma) and it worked once but it made my system laggy (edit: when i say laggy, i mean that my system either laggs like hell or it becomes unresponsive), firefox would take a good 2 minutes to start and to stop, i thought its a problem with the installation so i tried reinstalling the system 2-3 again (online mode with plasma and gnome) and that didnt work, i was getting pacman errors, then i went for the offline mode, which surprising always worked but the lag persisted, from the first install to this point i was getting MCE (machine check errors ) at boot so i thought it could be caused by them, after doing a tiny bit of research i found out it was either a cpu overheating problem or a memory problem so my father took the pc to the vendor for a servincing, and the lag and the errors still persist, i thought a system upgrade could solve the issue so i did a sudo pacman -Syyu and to my surprise my system didnt boot up after that, so i restored to a snapshot which i took before the upgrade, then i asked for help regarding this issue on the techut discord server and the ppl asked me to change the grub settings at boot, they asked me to remove the quite parameter and add an mce=off which did work halfway, it stopped when the screen printed [ OK ] Finished Loading/Saving random Seed. But then again my system won’t boot so currently i am a snapshot i took before the upgrade, also they recommended me to update the BIOS since that could solve the issue either. I need help with this problem guys, here are some images


grub config (removed quiet and added mce=off)

the machine check errors

Is it possible to boot on the live ISO? Post the link.

inxi -Faz --no-host | eos-sendlog

Edit: Current Bios version is F4 2021/11/01

Secure boot keys should be cleared and secure boot option disabled.

Edit:I have difficulty believing it is related to MCE error.

There is a possibility also that you have a bad ram stick. I would test the memory with bootable disc with memtestx86.

I am not sure wether it is related to the MCE, honestly, I don’t even care about those errors, I just want my system to function

I understand that. I’m just pointing out that the mce errors could be coming form bad memory. I don’t see any hardware info? Also you should update the Bios.

If you can boot on the live ISO and provide the hardware information could be helpful.

i did update the bios to F4, sending the
inxi -Faz --no-host | eos-sendlog
result

https://clbin.com/4vxLn

What graphics card do you have exactly?

Nvidia colorful GT 710

Did you install the nvidia drivers from the AUR package?

this is what neofetch says

NVIDIA GeForce GT 710 

1 Like

Ya…sorry i just missed it in the log.

i booted with the NVIDIA graphics mode on live usb while installing

Okay… are you able to boot and get into a TTY?

what is a TTY??

If you boot and it doesn’t load the desktop? ctrl alt f2 Then log in as root

i never tried getting in the TTY

Can you try booting and see if it will.

ohk
gimme a moment