(maybe) bug while installing on Raspberry PI4

This is the first post for me; please be patient :slight_smile:

I would like to report a probable reproduceable bug in the install process on Raspberry PI. I have a brand new 128GB SD card and my PI4 has 8GB of RAM. The SD card is OK because I tested it by filling it with N random files (dd from /dev/urandom) and I checked that the md5sum is the same: so no errors. And my Raspberry is also OK.

The first step seems OK: I ran EOS in live mode, inserted the SD card and the ARM installer seems to give no errors.
But when I insert the SD into the raspberry, a black desktop is displayed, without a background image, without any welcome application, without Calamares.
There are just four icons on the bottom left, but they don’t run any program. Same thing for the menu that appears when I right-click on the black background (I tried to run the terminal but it doesn’t start).

I tried again several times.
At the end, I’ve luckily found a workaround: I used the img file from here, wrote it with dd and now everything works fine now:

I suggest you to check the install process.

1 Like

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

I am about to feed the inner man and have Breakfast. After Breakfast I will do a test install and see if I can duplicate the problem.


Let’s try to figure out what is going on here.
Try going to

Then click on
enosLinuxARM-rpi-latest.img.xz AND enosLinuxARM-rpi-latest.img.xz.sha512sum

In a terminal, go to the directory where the files were downloaded to. Then

sha512sum -c enosLinuxARM-rpi-latest.img.xz.sha512sum
enosLinuxARM-rpi-latest.img.xz: OK

The results should be OK, this verifies the image was not corrupted during download.

Next, use an image burner to install the image on a uSD card or USB SSD
I highly recommend using gnome-disk-utility
I use it on any and all Desktop Environments. It seem to be DE agnostic, has few dependencies, and doesn’t take much memory. In fact, I am using KDE Plasma to do the test install. I have been using gnome-disk-utility for over a decade, and it just works.

In gnome-disk-utility (called “Disks” in the app launcher) select the target uSD card

I have the target device highlighted on the left, then click on the three vertical dots, and click on Restore Disk Image. Follow the prompts, and when finished, umount the uSD card. In the right side of the top panel, the up-arrow will umount the selected device.

When Disks is finished you will get someting like the following:

ROOT_EOS Partition 2 will show 6.2 GB with a lot of Free Space after it.
Don’t worry, when the uSD is booted and Calamares configures the OS, this Free Space will be added onto Partition 2.

Connect the uSD card to your RPi 4b and hopefully it will boot up into this

here is the promised image. This is what should appear on first boot only.

If you need advice with “Edit Mirrorlist” or anything else, please feel free to ask.

I tried to duplicate this test install to what you were using. I ran this install on a RPi 4b 8GB RAM, with the latest EEPROM update, on a Samsung EVO 128 GB uSD card.

If your install does not work with this process, the first thing I would suspect is the uSD card.
ARM devices are very finicky about uSD cards. If available, I would do some test installs on various size uSD cards from various manufacturers.

Also, make sure you are getting ddimg-rpi-20221203 from

and not from

The “test-images” repository is for testing purposes only.

Let us know what happens, and if it still doesn’t work, we will assist in trying to get it working.


FYI: There are three ways one can install EnOS on a RPi 4b.
The above procedure is METHOD 3 in the README.md for the endeavouros/images repository.


Hello. Thank you for the instructions and the support. Maybe you could consider publishing them publicly.
Anyway it was more or less what I did yesterday – this is what I meant by writing “At the end, I’ve luckily found a workaround: I used the img file from here, wrote it with dd and now everything works fine now”: I actually used the method 3 indeed.
And I succeded, actually now I have a working installation and I’m fully satisfied with EOS now (for some reason it runs faster than Manjaro and this is fantastic).
With my post I just wanted to report that I had a problem with the standard method, using the welcome app inside the live ISO and that this seemed a bug to me.


That no surprise ! :wink: :innocent:

Hope you enjoy rest of your EndeavourOs xp :vulcan_salute:


Sorry, I misread your OP. I’m glad you got things working and like it. The post is now here for other users. For me, on a uSD card, most DE / WM are quite acceptable with the exception of Gnome and KDE Plasma. They are a bit laggy at times. However, with the OS installed on a USB SSD, Gnome and KDE Plasma are very usable. I use KDE Plasma on a Samsung T5 500 GB device for all my RPi 4b dev work.

In the endeavouros/images repository, there is also a server-rpi-20221130 image one can use Method 3 to install a very bare bones headless server in case you are interested.

Welcome to the EndeavourOS community.



Thank you for the welcome.
At the moment I’m trying GNOME: I disabled animations and installed half of the extensions I regularly use.
On my Raspberry it’s just a little bit laggy, but it’s usable and I feel at home. Should I decide to abandon GNOME, I’d install XFCE, which is always been my second choice.
I’m using this SD card as a storage: it doesn’t cost too much and should be one of the fastest https://m.media-amazon.com/images/I/61ZAGqBUQjL._AC_SX679_.jpg

Besides feeling at home, one also has to consider the power savings as my Raspberry Pi 4 at idle only draws 3 Watts at the wall outlet. If I remember correctly, under a decent load it pulls between 5 to 6 watts.



That’s the thing… after i saw you posting wattage I checked what the x86 machines at my home watting out of the plugs…
If you do not need the full power for stuff you do and only need to browse the net emailing chatting and things like office… my odroid would fit all this with almost no power consumption compared to the full blows x86 machines :wink:

only browser open with one tab … watching yt video :wink:


I just fired up my Odroid N2+ connected to the Kill-A-Watt.
idle = 3 watts
load = 6 watts

I tried various load configuations, the highest reading I got was 6 Watt. Exactly the same as the RPi 4b.

When I get my back ordered power supply, I am anxious to see how many watts my Radxa 5b will pull when I get it fired up.


1 Like

Just to put things in the proper perspective, I hooked my AMD Ryzen 7 2700 Eight core CPU rated at 64 Watts TDP, with AMD Radeon RX 460 GPU rated at 65 Watts TDP, and 32 GB RAM to the Kill-A-Watt.

Before I pushed the power button to boot up, I noticed the Kill-A-Watt was reading 2 Watts.

The RPi 4b and Odroid N2+ both idle at 3 Watts, and the Ryzen computer has 2 Watts of standby power, or Ghost Wattage.

The highest wattage on the Ryzen was about 65 to 70 Watts while watching a MP4 video and streaming a you tube video in Firefox. Idle was about 30 to 35 Watts.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.