MATLAB problem after recent update

After the recent update it is not possible to start MATLAB. The terminal gives me the following prompt

MATLAB is selecting SOFTWARE OPENGL rendering.
/usr/local/MATLAB/R2021b/bin/glnxa64/MATLAB: error while loading shared libraries: cannot open shared object file: No such file or directory

I guess it has been something to do with the glibc library, when I see other threads referring to the update.

glibc just got updated and it seems that your build of MATLAB does not work with the new version of it.

How did you install MATLAB? Where did you get it from? Since this is proprietary software, it will probably have to be rebuilt against the new version of glibc.

If you can get away with it, I wholeheartedly recommend GNU Octave as an alternative to MATLAB.

I used the official installer provided by the MathWorks website

Try reinstalling it. If that does not work, you should contact them and ask for support. Let them know your version of glibc (2.35).

I’m not able to find it right now, but I remember someone saying that libcrypt will be removed from glibc and have another provider. I’m not 100% certain and have no other informations, nor experience with this, so take my comment with a grain of salt.

Try installing libxcrypt.

1 Like

This package is already installed. I also found the file and by linking to this file, there occured another error concerning GLIB.

I downloaded the newest installer and when calling ./install i get this

/home/username/Dokumente/Matlab/R2021b/bin/glnxa64/MathWorksProductInstaller: error while loading shared libraries: /home/username/Dokumente/Matlab/R2021b/bin/glnxa64/ file too short

Sadly I have no idea how to help you with this. Best place to ask would be the official Matlab forums.

There also is someone asking on the official arch forums. Maybe keep an eye on this. Or is that also you?

1 Like

No that’s not me, but thank you for this.

  1. There is an AUR package.

  2. See the latest comment on the page.

outloudvi commented on 2022-01-26 10:34 (UTC)

Please note that you may need to extract/unpack the installer with unzip instead of some GUI utilities (e.g. Ark), or some symbol links or so would be missing, and you will get such error messages when running ./install:

/tmp/matlab-instlaller/bin/glnxa64/MathWorksProductInstaller: error while loading shared libraries: /tmp/matlab-instlaller/bin/glnxa64/ file too short

There also is a detailed description on how to install MATLAB with the mentioned AUR package on the arch wiki.


1 Like

On the arch forum someone mentioned installing this package from the AUR.


Since you’ve paid for it, you’re entitled to support. I’d contact them.

1 Like

That solved this point.

Now nothing happens when I use ./install. I already tried several options, I found googleing.

I’ll do this :slight_smile:

1 Like

There’s an AUR package that provides compatibility for

(Already posted in MATLAB problem after recent update - #14 by I0F but the package name is hidden inside a link.)


I also had this problem ( with docker-compose and libxcrypt-compat fixed it.

Isn’t there some way to “avoid” situations like this? I mean, .so.1 got removed from glibc, but something still needed it (docker-compose, matlab, etc).

Well, in the end it’s a problem with the programs you use, because they are using a deprecated library. With the current glib release it finally got removed, so these programs should act accordingly.