Mate - marco 12/05/2023 - 12th may 2023

since update from 12/05/2023 , i have lost connexion on login ,
screen stay black after login , no error log in journalctl appears
( tested with 3 kernels )

is there a way to check another log or restart marco ?

I’m assuming you mean and update from 12/05/22 since 12/05/23 hasn’t got here yet. What connection are you loosing at login? What DE/WM Which Kernel? Normal/LTS/Zen Which Login Manager? What video?

back in time or back to the future :wink:

something like:

marco --replace

just tried in VM and it lags on login but after time Desktop shows up…
Could you simply try switching TTYs ?



to be more precise ,

  • date are JJ/MM/SSAA on my side
  • screen login appears , but just after login , desktop not appears , no log or error log in journalctl ( i have logged with TTy Ctrl + Alt F3 to F6 , F7 go back to Desktop )
  • i have tried startx , it works ( windows from 90 appears ) , but no marco
  • i have seen marco start is delayed but no other log or error

DE mate ( no problems on others side Xfce / Qt / sway )

1 Like

yes i can totally reproduce… and just checked it is not the DM (lightdm) i downgraded marco and it starts right away like it should… so seems related to marco i think…

sudo downgrade marco

and choose 1.26.0-1 …



I forget people display the date differently in different country’s LOL. I was thinking december not may 12th. damn


i downgrade to version 1.26.1-1 (11) 6 decembre 23h
there is no version marco 1.27.0 on side ( pacman or yay )

pacman -Qi marco
Nom                      : marco
Version                  : 1.26.1-1
Description              : A window manager for MATE
Architecture             : x86_64
URL                      :
Licences                 : GPL
Groupes                  : mate
Fournit                  : --
DĂ©pend de                : libcanberra  libgtop  mate-desktop  zenity
                           libxpresent  gettext  libxres
DĂ©pendances opt.         : --
Requis par               : mate-control-center
Optionnel pour           : --
Est en conflit avec      : marco-gtk3
Remplace                 : marco-gtk3
Taille installée         : 6,38 MiB
Paqueteur                : Antonio Rojas <>
Compilé le               : mar. 06 déc. 2022 23:03:47
Installé le              : sam. 13 mai 2023 14:52:09
Motif d’installation     : Explicitement installé
Script d’installation    : Non
Validé par               : Signature

option after TTY to launch marco --replace works , but not on the first login

but what the hek? why it shows 1.27.0 inside downgrade ?
aha i see someone updated the package to 27 and it was reverted…:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.