MATE Install Issue

Hi there EndeavourOS Forum!

Brand new Endeavour user here. Been daily driving EOS for a week now with XFCE and Cinnamon, and I absolutely love the experience so far. I don’t know the technical details behind it, but my desktop has never performed this well.

However, I installed MATE alongside Cinnamon and XFCE, but cannot get it to open when selecting it in the login screen and punching in. The screen goes black, the audio goes ‘click’ and it returns me to the login page.

Just checking to see if there is a solution, as I would love to try MATE alongside the other DE’s installed. Will obviously re-install if need be, but wondering if there is a way to resolve this issue using the terminal.

Thanks in advance!

What I would do is read up on (if necessary) adding a user to your system, login AS that user, then install the MATE DE packages. This way you can try it out without any conflicts in config files etc which are all too likely when mixing DEs under one user.

Some combos are fine - especially a DE with a WM - but others can have conflicting needs in config files, especially if they all use (for instance) GTK for display and so on.

The other ‘obvious’ way is to spin up a virtual machine to run tests on - or multi-boot if you have the disk space for that. THAT takes some reading too, though, which you may not want to snow yourself under at this stage!

BTW - minimum user adding command (including use of sudo if needed for that user):
useradd -m -G wheel newusername

1 Like

And of course, welcome to the community :beers:

1 Like

Welcome to the :enos: forums.

Might be MATE is in conflict with Cinnamon under the same user.

1 Like

I think there may be an issue with all the installs I’ve added with display managers and DE’s. The new user option gives me the same ‘click’ and logout issue, so I think I noob installed EOS and broke some files with too many DE installs. For example, GNOME has 4 options to choose from in the login menu, so I think I’m going to do a fresh reinstall to clean-up, and then put MATE on a spare laptop to try. :slight_smile:

Thank you for advice.

Thank you! Excited to be here. :beers:

Thank you!

Yeah, I think over installing DE’s may have burnt something here.