Many icons vanished

Hi,
since an update yesterday or two days ago many icons are gone. Application icons and icons within applications. I use global theme “Breeze”. I played around with other themes and “Oxygen” is working correctly. But all other themes I tried have missed all or many icons. Because of one theme is working I think it is related to the themes itself - but reinstalling does not fix it. Very special behaviour… three computers (all use an “Endeavour” which was born as “Antergos” and migrated) are affected same way.
Any hints are welcome.

may some error messages logs e.t.c. ?

No error messages during update or in the logs. But definitely there was something updated which causes the issue.

A possible interesting line in pacman log could be this one:

running ‘gtk-update-icon-cache.hook’…

I have turned one of the computers to life again by randomnly change global themes and at last rebooted with theme “Breeze” while icons are missing. After reboot they are back again and icons at all other themes, too. Sadly I was not successful at the other two computers. It seems that the way I changed the themes has an influence :frowning: Can I trigger rebuilding of icon cache by hand?

Are you using KDE? I noticed that icons don’t work properly anymore unless you install them directly through the KDE settings module. KDE now installs a shortcut folder in the icon pack called “categories” that isn’t there you if manually download and extract the icons, then move them to the folder.

If you want to download multiple varieties of icons from the same theme, you’ll have to download them one at a time through KDE settings, then move your downloaded icons to another folder, then uninstall the nonexistent icon pack so that KDE settings allows you to install a new set of icons from the same theme, then move the other ones back into the icons folder

The only real problem I have with KDE is only allowing one install per theme through their settings manager. Many icon themes have lots of different variations and colors. The way I described to get around it works fine

This is something new with KDE across all distros because I used to always manually download icons without a problem

1 Like

Thanks for your reply. I am using KDE - therefore my question is inside this category… I will try your suggestion. At this moment I am unable to decide if the problem is in my home folder, or in the “grown and migrated” installation, or if it is a generally problem. My Arch based systems are alive from ~August 2018 and this is the first time I run into this issue. This is very good - my Debian based roling release ran into dozens much more complicated issues during this span :upside_down_face:

Hi!
I suspect with this update some icons are depending on another icon theme or simply changed the name.

One thing you can do is check dependencies form one of them like
pacman -Si breeze

OBS: if you don’t know exactly the theme name you can serach for it with pacman -Ss breeze

then try installing it’s dependencies as needed with sudo pacman -S PACKAGES --needed

Try updating the system again too…

2 Likes

Hi Fernando,
your suspection was my solution (and I hope others, too). After stepping through this everything looks and works as before.

Best regards - stay healthy!
df8oe

1 Like

Glad I could help!
Wish you well and for your family too!