Manual install of sway - Think I have missed something

imv swaylock.png
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  10 (X_UnmapWindow)
  Resource id in failed request:  0x0
  Serial number of failed request:  8
  Current serial number in output stream:  8

If I run imv 3-4 times it stops working with the above error (as does viewnior). Think it is something to do with XDG_RUNTIME_DIR but there is very little out there. swhkd is working but keeps saying:

[2022-03-27T10:33:33Z ERROR swhkd] XDG_RUNTIME_DIR has not been set.

I cloned the repo and installed manually, other than the above, I have no issues (and swayimg works fine).

Hope the above makes sense!!!

Have you installed the xdg-users-dirs package and run xdg-user-dirs-update after that?

Makes no difference (and yes it is installed, had I run it previously, no idea :rofl: ).

What do all of the following words have in common:

  • Wazock
  • Numpty
  • id10t

They all describe me.
There is a separate imv program imv-wayland for wayland - doh!!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.