Manjaro to EndeavourOS experiences

Always Knew you were a Windows Lover really Lol


I’m curious to try EndeavourOS; I’m mainly using Manjaro at the moment because I’m too lazy to set up Arch from scratch like I used to and the default setup (mainly the theme) is quite nice. What is the out of the box experience of EOS in comparison? Based on the description it seems like it requires more customization from the end user but the terminal focus doesn’t bother me (I’ve never used pamac for example).


Welcome! :rocket:

Very close, it’s as easy to install and use (if you choose online installation and other than XFCE DE - it might take longer to install, because requires downloading from internet)

Depends on your DE choice and taste really, all DEs are shipped pretty much as is, with their native defaults :slight_smile:

And system itself is very close to Arch on how it behaves and maintains :wink:
It’s best to try in VM if you’re in doubt though, no need to go full metal from start :upside_down_face:


No, we dont, in fact we don’t even have the time to turn it into that. As said earlier, we even dropped features that Antergos was shipping, just to keep it managable.


Thanks mate, appreciate the reply. Hmm, that being the case I’ll see what extensions and theme Manjaro uses for gnome3 and maybe give EOS a whirl with those.

Both Manjaro and EndeavourOS are based on Arch, but Manjaro has its own repos, while EndeavorOS uses the Arch repos (apart from having an additional one for some useful utilities, scripts and some basic theming). This is a big difference.

On Manjaro, the repos are built from the Arch repos, but the Manjaro team modifies many packages, like kernels for example which are custom built for Manjaro (a lot of packages in the Manjaro repos contain customised settings and Manjaro-specific theming). A big difference is in updates: Manjaro has its own stable and testing branches which delay updates. For example, on Manjaro stable the updates are pushed maybe once in a couple of weeks, and they are huge, often several gigabytes.

On EndeavourOS you directly download packages from Arch mirrors, there is no middleman. You are basically running a pure Arch system. The updates are similar to Manjaro unstable branch, very frequent and small: there are new updates every day, sometimes several times a day. Of course, you don’t have to update straight away, you have full control over updates.

On EndeavourOS, just like on vanilla Arch, there is no MHWD, so you have to know which drivers you need. For older or more obscure hardware, the drivers might not be in the Arch repos, so you have to install them from the AUR. The same is true for older kernels: for example, if you want to run kernel 4.19, you have to install it from the AUR. On the other hand, unlike Arch, EndeavourOS has an additional repo with a handful of great scripts and utilities that can help you a lot in this regard. This additional repo also has yay so you don’t have to build it manually. Instead of Manjaro’s pacman-mirrors script, you use reflector (which is much better, actually) or you have to manually configure the mirrors.

The default install of EndeavourOS is much cleaner than Manjaro’s default install, though both can be customised, of course. Out of the box, EndeavourOS is very lean, has almost no bloat at all (no snapd, no Steam, no FreeOffice garbage), and very little theming (except for the offline Xfce install, if I’m not mistaken). It also does not do stuff behind your back (for example, there is no annoying pamac-timer service that automatically resets your mirror config every week, like on Manjaro).

What else? There is this forum, which is probably the best thing about EndeavourOS, a very friendly place with many users willing to help you. :smiley:


Oh and to @Kresimir’s point - if you don’t like frequency of updates, you can try @jonathon’s solution:


Hvala puno :slight_smile:

The more regular update cycle is good to hear. That’s a plus to me. Will definitely give it a try and see how it feels running on my system. I also wasn’t aware of the mirrorlist being reset on manjaro…that’s actually kinda annoying. At least I’m aware of it now in case my download speed tanks for updates.



My week so far has been really peaceful. Last weekend not so much… :upside_down_face:


Manjaro Linux
15 Std.
Update on forum situation: We failed in recovering the uploads.

So far all 378191 are lost.

We tried to recover some from, but it seemed not working with the approach we tried. Currently we are discussing how we should bring the forum back online.

Manjaro Linux
Our #team is working hard to get the new @ManjaroLinux
forum up and running in no time. Here a glimpse of our ongoing work …
10:01 vorm. · 13. Aug. 2020·

378191 apples, pears, pictures?

Time to officially quit as it seems that all essential things have been destroyed.


This is such a terrible tragedy! :sob: :scream: So much user artwork lost. Literally thousands of user generated wallpapers!!!


Holy crap… :exploding_head:

1 Like

I think I still have mine but will certainly not upload them there.

It’s like, “Make sure you use a secure password. 20 digits, lowercase, uppercase, special characters.”
And then all personal data, accounts, etc. are stolen/copied directly from the server by hackers. :smiley:


So, just tried installing it in a VM and things haven’t gone too well. In VMware Player it wasn’t getting past the loading screen and in VirtualBox I’ve had it fail several times during the install. The first 2 times it took forever to install (the GUI was stuck at 23% while the background terminal was installing packages) before getting this same error message. Screenshot of the error message that comes up after it fails:

It also hung/crashed when changing the screen size so at this stage I might hold off for a bit until a new release of the install ISO before I give EOS another crack. Thanks for the warm welcome at least everyone. Hopefully next time it goes a bit more smoothly.

1 Like

It’s an issue with virtual box: please refer to this thread before giving up :yum:


Thanks for the heads up :slight_smile: I’ll give it another try when I’m back on my desktop. Fingers crossed :slight_smile:



Glad I’m not there really any more tbh. That sucks. I imagine they got hacked and someone trashed their DBs?

1 Like


It still took forever to install, and I’m not sure why; I have a really fast internet connection but it got there in the end. As mentioned, it’s a vanilla install basically but some nice helper functions (helping me sort out mirrors for updates for example) and it’s got yay installed by default; very nice!

If you’re like me and like the look of Manjaro and are looking to use gnome3 on EOS as well, these are the commands you’re probably after:

yay -S matcha-gtk-theme-git
yay -S xcursor-breeze
pacman -S papirus-icon-theme

The first installs the theme, the second the mouse cursor icon used and the last the icon set. The final thing you’re probably after is the gnome extension “dash-to-dock” which give you that ubuntu-esque sidebar (though you can place it anywhere).

All in all looks good. When I get a chance I think I’ll switch over to EOS.


When I did the installation the first time (online KDE) I also thought it was stuck (on 25% progress), but after checking PiHole on my RPi, I noticed the machine was contacting “” every 15th second. It took about 45 min, then the install continued. I have read somewhere that various keys are downloaded in this step (noob here, don’t know the exact details).

Second installation (after I had destroyed Plasma by trying to customize themes without knowing what I was doing :upside_down_face:) the install was much quicker, no delays. I think there is a thread on the forum about some problems related to getting keys and delays.