Mangohud crashing Steam in the background

This is the last thing stopping me from ditching windows completely, so I’d really appreciate any help I can get.

I launch my game with mangohud %command% in the launch options and everything is great for 15-30 minutes, but then steam will crash silently in the background and I’ll get some “disconnected from the network” message ingame before the game itself freezes shortly after.

I’m really not sure what to make of it. I’m leaning a little towards user error as it seems to be a very popular tool that just works for everyone, but I also just tried a clean install of endeavor os today and it’s still a problem. I did install my usual stuff before testing so I cant be 100% sure, but it wasn’t anything that I can imagine would conflict somehow. Web browser, discord, mpv, obs, terminal themes, cloud storage, and cryptomator already covers most of it.

I managed to find a few posts on various forums about what seems to be the same problem, but I had to dig pretty deep to find them and none of them found any solution other than “dont use mangohud”. They all seem rare enough that it seems likely that all of us with this problem managed to mess it up somehow, rather than it actually being a problem with mangohud. I saw a couple github issues about it, but they all seem dead.

I’ve asked about this elsewhere before and someone had me get some output from steam with steam &> $HOME/steam-output.txt, but that’s as far as I’ve ever gotten. I’m still relatively new to linux and am not an expert on providing logs, so I’ll just add the first two from the systemlogs guide here and call it good. Actually, that journalctl one is giving me a 413 Request Entity Too Large in html instead of my link, so I’ll need assistance with that too if it’s relevant.

I’ve tried my best to troubleshoot, but I’ve failed to really find anything worth mentioning. The only noteworthy thing I managed to do was to test older versions, compiling 0.6.4 and 0.5.1 from the github. Neither of these made any difference.

Hardware info:
Doesn’t look like I’m allowed to upload that steam-output.txt either, so let me know what I should do with that.
The steam output is on pastebin now:

The clbin link above also seems to be dead? Here’s the hardware info on pastebin too:

Sounds very similar to this issue related to newer versions of MangoHUD:

Try 0.6.4 from the AUR and see if that works. If it does, it’s the same problem.

Otherwise, it will be worth checking for and filing a bug report on the MangoHUD issue tracker.

I mean, if MangoHUD causes crashes then not using it is a valid solution. Does it really provide critical functionality for playing games?

I can’t help but feel this is the wrong forum, especially given how much extra “stuff” Manjaro includes… Otherwise, splitting effort between multiple fora is pretty bad form.

1 Like

Did you create a custom MangoHud.conf file?
Have you tried disabling Steam in-game overlay?
Is Steam installed as a binary package or with flatpak?

I edited my post earlier to add that I tried some older versions from the github and still had crashes. I could try from the AUR if you think it would make a difference.

Maybe it’s weird, but it is important to me. On windows, I’d spend hours customizing my rivatuner overlay to perfection and then I’d have it up nearly all the time. I have been making some changes to my hardware over the last few months, so I especially like it to make sure my temperatures and frames are as expected, and I also just like seeing numbers somtimes.

tl;dr, I can’t really accept “dont use mangohud” as a solution. I need it to work if I am to leave windows.

Sorry, I forgot to clarify that part. That steam output is from around a week ago when I was using manjaro, and I eventually gave up troubleshooting and this problem combined with various other complaints I had with manjaro convinced me to start over here with endeavor os. Unfortunately it’s still broken somehow, even after a clean install. I haven’t posted to the manjaro forum.
I could get the log again on endeavor os if you would like. I haven’t yet as I expect the errors to be the same, and the errors in that log didn’t seem to mean much anyway.

Currently it’s just the “full” preset from GOverlay, I haven’t bothered to manually customize it at all while it’s still broken.

I have not, but I will try that and get back to you soon.

Binary package I assume, installed with pacman

1 Like

As a relatively new linux user, what logs/dumps or whatever other files should I provide when I do make a github issue about it?

There’s already an issue there that I initially thought was something else, but we’ve talked some more about it and it sounds like we have the same thing so I shouldn’t need to open my own. I would still like to know what information I should provide to help out though

edit 2:
Disregard that, it’s a different issue. I’ll do more testing and get all the info I can, any guidance would be appreciated

edit 3:

Tested this now, it still crashes even with the steam overlay globally disabled from steam settings.

Oh, so you are running GOverlay in addition to MangoHud?
In that case maybe GOverlay is the issue here.

Would GOverlay be actively doing anything? I assumed it was just meant for configuring the other tools. Or could it configure mangohud in a way that might cause problems?

It doesn’t seem likely, but it’s possible. I would run a test with MangoHud on its own, without GOverlay.

I’ll work on it, thanks. I just realized the guy jonathon spoke to about a similar issue is actually the same one I’ve been talking to. We don’t seem to have the exact same symptoms, but we do both have a pretty heavy config file that’s doing more than just reading sensors. I’m thinking it’s more likely an issue with one of those than with GOverlay itself. I’ll try writing my own config with all the numbers I want but without any of that extra stuff, and doing some testing with that. Hopefully I’ll have some results next time I’m here.

1 Like

I almost feel guilty needing to come here and be told that to figure it out, but I think that was the case. It hasn’t been long enough for me to be 100% certain, but I haven’t been able to get it to crash with any games I test using my new config so far. It seems I was a fool to trust that the preset would work correctly.

I’ll still give it a few days to be safe, and then I’ll mark it as solved if it continues to work. Hopefully I do eventually find which specific setting it was that was causing the problem so I can report it.


I think it’s safe to say it’s working now. GOverlay put an exec option in my config to read my distro info and some other stuff from a file, and it has been working flawlessly ever since I removed that. I’ve found 3 other people with this issue now, and they all also tracked it down to that setting and it’s been fine for them too since removing it.


Glad to hear you sorted it out, thanks for sharing your solution too. :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.