Malformed MSFT vendor event: 0x02


Does anyone know how to resolve the following error?

I am unable to boot but I can access the tty.

I updated with yay, and rebooted multiple times but the error won’t go away. Any ideas?

Below is additional information.

But bluetooth should never have anything to do with being unable to reach the graphical login. It’s a totally separate system, and very unreliable in my experience.

So down to diagnosis of the graphical mode not working, you will need to look at the /var/log/Xorg.0.log file for clues.

Thanks but after hours of hitting my head on the keyboard I decided to just reimage.

Going to give it EOS another shot and if it fails again after only about 24 hours of use then I’m done.

1 Like

EOS is just Arch with a few helpers. Any issues Arch has are therefore in EOS too. That said, it is the most reliable and updated Linux I’ve run since I started seriously with Linux in 2002. Usually if there is a problem the problem is due to the hardware (nVidia is the main culprit).


Yeah and I think EOS is great. In the small amount of time I’ve used it I loved every part of it.

But it’s really demoralizing when after you just got everything set up perfectly you run a yay command, reboot and poof it’s all gone.

Hopefully the time shift backup I captured last night works.

It’s back!!!

Time shift failed and I manually installed everything again.

It’s worse now I can not find my windows drive to boot to, it disappeared.

I took a look at the link you provided earlier. I tried a few commands to turn off Bluetooth but it did not do anything.

As for the log file, I am not sure what I am supposed to be looking for inside of it.

I honestly think this happens when I enable the Bluetooth service. As that was one of the last things I did when I rebuilt it.

I decided to re-image again, lost count at this point.

I also asked ChatGPT what I should do, below is its output.

If I run into this issue again ill try the below.

The error message you provided, “Bluetooth: hci0: Malformed MSFT vendor event: 0x02,” is related to Bluetooth on your Linux system. It indicates that there is an issue with the Bluetooth vendor event data that the system is receiving, which is causing the Bluetooth subsystem to fail during boot. To troubleshoot and resolve this issue, you can try the following steps:

  1. Boot into Recovery Mode:
    If your system is not booting properly due to this error, you can try booting into recovery mode. Most Linux distributions have a recovery option in the boot menu that allows you to access a root shell prompt.

  2. Disable Bluetooth Service:
    Once you have access to the root shell, you can try disabling the Bluetooth service temporarily. Use the following commands:

For systems using Systemd (Ubuntu, Fedora, Arch, etc.):

systemctl disable bluetooth

For systems using SysVinit (older versions of Ubuntu and Debian):

update-rc.d bluetooth disable
  1. Update the System:
    Outdated software can sometimes cause compatibility issues. Make sure your system is up-to-date with the latest packages and drivers. If you can boot into your system normally, run the following commands:

For Debian/Ubuntu-based systems:

sudo apt update
sudo apt upgrade

For Red Hat/Fedora-based systems:

sudo dnf update
  1. Check Bluetooth Configuration:
    Inspect the Bluetooth configuration files for any potential issues. The main configuration file for Bluetooth can typically be found at /etc/bluetooth/main.conf. Use a text editor to open it and check for any misconfigurations or invalid settings. You might want to comment out certain options or revert them to default values.

  2. Check Kernel Messages:
    Examine the kernel log to get more information about the issue. You can use the dmesg command to view the kernel ring buffer messages and search for Bluetooth-related errors:

dmesg | grep Bluetooth
  1. Check Hardware Compatibility:
    If you’ve recently added new hardware to your system or updated firmware, it’s possible that the hardware or firmware is not fully compatible with Linux. Try reverting any recent changes to see if the problem persists.

  2. Downgrade/Upgrade Bluetooth Firmware:
    If the issue started after a firmware update, you might consider downgrading the firmware to a previous version or, if available, upgrading it to a newer version.

  3. Report the Issue:
    If none of the above steps resolve the problem, it might be a bug in the Linux kernel or Bluetooth stack. In such cases, you can report the issue to the Linux distribution’s bug tracker or the upstream Linux kernel Bluetooth mailing list with the details of your system and the error message you encountered.

Remember that dealing with boot-time issues can be sensitive, and misconfiguration or incorrect commands can potentially cause further problems. If you are unsure about any of the steps, it’s best to seek help from experienced Linux users or the community support forums for your specific Linux distribution.

Also the other issue I had due to re-imageing EOS was that I lost the ability to select Windows 10 from systemd and from the firmware.

Below is what chatgpt said.

f you’ve installed Linux alongside Windows 10 and now cannot see the Windows drive in the boot options, it’s likely that the Linux installation has overwritten or modified the bootloader configuration. To regain access to Windows 10, you need to restore the Windows bootloader and add an entry for Windows in the boot menu. Here’s a step-by-step guide to achieve this:

Please note that the exact steps may vary depending on your Linux distribution and system configuration. However, the general approach should be similar.

Step 1: Boot from Windows Installation Media

  1. Insert the Windows 10 installation USB or DVD into your computer.
  2. Restart the computer and boot from the Windows installation media. You may need to change the boot order in the BIOS/UEFI settings to prioritize the installation media.

Step 2: Access Windows Recovery Environment

  1. When the Windows installation screen appears, choose your language preferences, and click “Next.”
  2. Click on “Repair your computer” (usually located at the bottom left corner of the screen).
  3. In the Windows Recovery Environment, select “Troubleshoot.”

Step 3: Restore Windows Bootloader

  1. Select “Advanced options.”
  2. Choose “Command Prompt.”

Step 4: Rebuild the Boot Configuration Data (BCD)

  1. In the Command Prompt, type the following commands one by one and press Enter after each:

bashCopy code

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

The last command may prompt you to add the Windows installation to the BCD. Type “Y” (Yes) and press Enter.

Step 5: Reboot

  1. After the commands execute successfully, type exit and press Enter to close the Command Prompt.
  2. Click on “Continue” to restart your computer.

Step 6: Update GRUB (Linux Bootloader) Now that you’ve restored the Windows bootloader, you should be able to boot into Windows. However, in some cases, the Linux bootloader (GRUB) may not automatically detect the Windows installation. If that happens, follow these steps to update GRUB:

  1. Boot into your Linux installation.
  2. Open a terminal or command prompt.
  3. Update GRUB using the following command:

bashCopy code

sudo update-grub

Step 7: Verify and Test

  1. Restart your computer and check if you can see both Windows and Linux in the boot menu.
  2. Test both options to ensure they are working correctly.

If you followed these steps correctly, you should now have the option to boot into both Windows 10 and Linux from the boot menu. If you encounter any issues or error messages during this process, double-check the steps and seek help from the community or support forums for your specific Linux distribution or Windows version.