Make EndeavourOS use local time for the hardware clock (RTC)

Hi, I’m dual booting EndeavourOS with Win10. This works perfectly with one exception… time.
In debian I was able to fix this with timedatectl set-local-rtc 1 to make linux use the local time for the hardware clock (RTC)
Is there such a command I can run that will make EndeavourOS do this also?

Many thanks

Have you tried timedatectl set-local-rtc 1 ?

1 Like

Er… no I assumed arch and debian were like chalk and cheese :laughing:


That command is part of systemd. It should work on any distro using systemd.

You are a star, thank you.
Also… I am still laughing here

1 Like

No, more like Brie and Cheddar.

1 Like

but not crackers to use it

1 Like

EOS wil automatically sync the correct time (takes a little while). Windows 10 will not. That is my experience. It is just as simple to tell windows to use UTC and fix it that way:

Open a windows 10 CMD with admin privledges and enter:

Reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_QWORD /d 1

This will create a registry key in windows forcing UTC instead of local.

Reboot into windows 10.

Set the clock to the correct time.

The time in windows should now allways be correct.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.