Mailspring failing to launch after update

Today after I ran normal updates, mailspring failed to launch. I initially thought it was an issue with the mailspring update itself… but downgrading gave me the same errors.

Running database migrations
App load time: 104ms

{"error":null}
Manual update check (updates.getmailspring.com/check/linux/x64/1.8.0-8983dca2/anonymous/stable) returned 204
mailspring --type=renderer --no-sandbox --autoplay-policy=no-user-gesture-required --js-flags=--harmony --enable-features=SharedArrayBuffer --service-pipe-token=13091887987947762857 --lang=en-US --app-path=/usr/share/mailspring/resources/app.asar --user-agent=Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Mailspring/1.8.0 Chrome/69.0.3497.128 Electron/4.2.12 Safari/537.36 --node-integration=true --webview-tag=true --no-sandbox --background-color=#fff --num-raster-threads=4 --enable-main-frame-before-activation --service-request-channel-token=13091887987947762857 --renderer-client-id=6 --shared-files=v8_context_snapshot_data:100,v8_natives_data:101: ../src/workers/open.cc:28: virtual void OpenWorker::Execute(): Assertion `sqlite3_db_mutex(db->db_handle) == __null' failed.
mailspring --type=renderer --no-sandbox --enable-features=SharedArrayBuffer --service-pipe-token=1413281416201667411 --lang=en-US --app-path=/usr/share/mailspring/resources/app.asar --user-agent=Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Mailspring/1.8.0 Chrome/69.0.3497.128 Electron/4.2.12 Safari/537.36 --node-integration=true --webview-tag=true --no-sandbox --background-color=#fff --num-raster-threads=4 --enable-main-frame-before-activation --service-request-channel-token=1413281416201667411 --renderer-client-id=4 --shared-files=v8_context_snapshot_data:100,v8_natives_data:101: ../src/workers/open.cc:28: virtual void OpenWorker::Execute(): Assertion`sqlite3_db_mutex(db->db_handle) == __null' failed.
Failed to get crash dump id.
Report Id: {"success":true}
Failed to get crash dump id.
Report Id: {"success":true}

Deleted its folder in ~/.config as well to see if getting rid of the DB would help.

I found this NixOS github issue with a similar problem, but I’m not sure how to apply their fix.

These are the packages I updated today
[2021-03-14T00:22:18-0500] [ALPM] upgraded attr (2.4.48-3 -> 2.5.0-1)
[2021-03-14T00:22:18-0500] [ALPM] upgraded acl (2.2.53-3 -> 2.3.0-1)
[2021-03-14T00:22:18-0500] [ALPM] upgraded dconf (0.38.0-1 -> 0.40.0-1)
[2021-03-14T00:22:19-0500] [ALPM] upgraded eos-translations (1.1.13-1 -> 1.1.14-1)
[2021-03-14T00:22:19-0500] [ALPM] upgraded mesa-tkg-git (21.1.0_devel.136301.5abefcb9628-1 -> 21.1.0_devel.136424.8283ed65cfd-1)
[2021-03-14T00:22:20-0500] [ALPM] upgraded gtk3 (1:3.24.26-2 -> 1:3.24.27-3)
[2021-03-14T00:22:20-0500] [ALPM] upgraded eos-bash-shared (1.5.28-1 -> 1.6-1)
[2021-03-14T00:22:20-0500] [ALPM] upgraded flameshot-git (r1288.984d004-1 -> r1295.1726d0a-1)
[2021-03-14T00:22:20-0500] [ALPM] upgraded gptfdisk (1.0.6-1 -> 1.0.7-1)
[2021-03-14T00:22:20-0500] [ALPM] upgraded lib32-attr (2.4.48-2 -> 2.5.0-1)
[2021-03-14T00:22:20-0500] [ALPM] upgraded lib32-acl (2.2.53-2 -> 2.3.0-1)
[2021-03-14T00:22:20-0500] [ALPM] upgraded lib32-atk (2.36.0-1 -> 2.36.0-2)
[2021-03-14T00:22:20-0500] [ALPM] upgraded lib32-gnutls (3.7.0-2 -> 3.7.1-1)
[2021-03-14T00:22:21-0500] [ALPM] upgraded linux-zen (5.11.5.zen1-1 -> 5.11.6.zen1-1)
[2021-03-14T00:22:23-0500] [ALPM] upgraded linux-zen-headers (5.11.5.zen1-1 -> 5.11.6.zen1-1)
[2021-03-14T00:22:23-0500] [ALPM] upgraded mangohud-common-git (0.6.1.r100.g30cdc91-1 -> 0.6.1.r101.g8f3ecb8-1)
[2021-03-14T00:22:23-0500] [ALPM] upgraded mangohud-git (0.6.1.r100.g30cdc91-1 -> 0.6.1.r101.g8f3ecb8-1)
[2021-03-14T00:22:23-0500] [ALPM] upgraded plasma-workspace (5.21.2-1 -> 5.21.2-2)
[2021-03-14T00:22:24-0500] [ALPM] upgraded plasma-desktop (5.21.2-1 -> 5.21.2-2)
[2021-03-14T00:22:24-0500] [ALPM] upgraded python-defusedxml (0.6.0-6 -> 0.7.1-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded python-importlib-metadata (3.4.0-1 -> 3.7.2-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded python-keyring (22.3.0-1 -> 23.0.0-2)
[2021-03-14T00:22:24-0500] [ALPM] upgraded python-setuptools (1:53.1.0-1 -> 1:54.1.1-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded rubberband (1.9-1 -> 1.9.1-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded ruby-reline (0.2.2-1 -> 0.2.4-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded ruby-irb (1.3.0-1 -> 1.3.4-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded s-nail (14.9.21-1 -> 14.9.22-1)
[2021-03-14T00:22:24-0500] [ALPM] upgraded teams (1.4.00.4855-1 -> 1.4.00.4855-2)
[2021-03-14T00:22:25-0500] [ALPM] upgraded wine (6.3-1 -> 6.4-1)
[2021-03-14T00:25:47-0500] [ALPM] upgraded mailspring-libre (1.7.8_libre-1 -> 1.8.0_libre-1)

How can I figure out what the root cause of this is?

2 Likes

This is an AUR package, so first thing I would do is check AUR comments.

https://aur.archlinux.org/packages/mailspring-libre/

See if others are having this issue and try and potentially resolve it collectively.

Raise an issue on github.

You could try mailspring to see if the issue is with the libre fork only? Looks like this update is a major version bump.

2 Likes

There are no comments on the primary AUR, but the libre-mailspring one has a comment that it is failing as well. I have two machines crashing/failing to open, and I have nuked the .config/mailspring folder with no success. Too bad since I have been using it for a couple of years and it has been getting a ton of run recently from the regular YT guys. Geary it is until this is resolved.

Might want to take a look at Zoho Mail. Great program and is in appimage form. Just if you do use it ignore the fuse error message. After trying to launch Zoho 3 or 4 times that message will go away.

1 Like

I’ll give it a look.

2 Likes

Forgot to mention that you also have an online account so all your personal settings are always saved.

1 Like

I tried both normal and libre. Same issue. It’s something to do with a different package that got updated on my system, as installing older versions that I know worked before don’t anymore.

1 Like

I know it is sacrilegious to install a snap in Arch, but this is precisely the reason I keep snapd installed. Pacman -Rns mailspring, delete the .config/mailspring folder, snap install mailspring, profit! I ran that snap for a long time before moving to Endeavour, and it is kept up to date very well.

Installing the appimage from the AUR doesn’t seem to be happy with my system

Oops ! something snapped !
Please check your Internet connection & condition >> Try relaunching the app >> Contact support
Technical details
Code: -107
Description: ERR_SSL_PROTOCOL_ERROR

Edit: Seems to be an issue with https://www.zoho.com/ as a whole. Gives me a similar error in the browser.

Found the root cause, gtk3. Downgrading to 1:3.24.26-2 lets me launch mailspring again.

Is mailspring-libre a binary package?

If so the maintainer just needs to rebuild against updated gtk3, otherwise should really be reported upstream so this issue can be patched.

Downgrade is only a temporary solution.

I don’t think so? To be honest, I’m not 100% clear on what separates a binary package from non-binary in the AUR.

I’m writing up an issue right now on the gtk gitlab.

Non binary packages you have to compile yourself from source, binary packages are compiled by the maintainer and you just install the resulting package.

The mailspring-libre github page is probably better, I don’t think this issue is with gtk3.

Ah, then no. It downloads the .deb and does the compiling.

Very well! Though it does affect both main mailspring & libre versions.

Seems there’s already an issue opened on the main mailspring forums

1 Like

.deb is a Debian packaged binary, so most likely this needs a rebuild.

Not sure how closely tied at the hip mailspring-libre is to mailspring.

The purpose of it was to strip out the requirement of needing a mailspring.com login, though the main project announced they will be removing the requirement.

You don’t install a Appigage through your software manager. The below is the official download.

Personaly I’d file a bug report in both places.

Seems that zoho doesn’t like mullvad. I just get an error when trying to connect either to the site or opening the app. Oh well, doesn’t matter as the GTK3 update fixes the issue with mailspring.

2 Likes