MacBook 2010 freezing after Idealing for X-amount of time

After installation I experienced an issue with MacBook 7.1 1.0 2010 model. System info is: Intel Core 2 Duo P8600, running Nvidia Geforce 320 GPU with 8GB of memory.

I switched to the Nouveau driver and that seemed to have solved the random system freeze.

I have just noticed that If I am on the system continuously all is good. However, If I leave the system for some time and come back there is a total freeze and the only way out is a hard reboot.

Any ideas/help would be appreciated.

Seem specific to this model of MacBook. Other two computers, including a Mac Mini, are OK.

What? Me Worry! I know what I know because I know it …

sudo inxi -Fxzmc0

so we can all see what you have

Thanks for the reply: Here is the inxi report.

System: Kernel: 5.11.16-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.16.0
Distro: EndeavourOS base: Arch Linux
Machine: Type: Laptop System: Apple product: MacBook7,1 v: 1.0 serial:
Mobo: Apple model: Mac-F22C89C8 serial: UEFI: Apple v:
date: 12/19/2018
Battery: ID-1: BAT0 charge: 49.6 Wh (74.4%) condition: 66.7/63.2 Wh (105.4%) volts: 11.6
min: 10.9 model: SMP bq20z451 status: Discharging
Memory: RAM: total: 7.52 GiB used: 671.6 MiB (8.7%)
Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB note: est.
Device-1: DIMM0 size: 4 GiB speed: 1067 MT/s type: DDR3
Device-2: DIMM0 size: 4 GiB speed: 1067 MT/s type: DDR3
CPU: Info: Dual Core model: Intel Core2 Duo P8600 bits: 64 type: MCP arch: Penryn rev: A
cache: L2: 3 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 9558
Speed: 796 MHz min/max: 798/2394 MHz Core speeds (MHz): 1: 796 2: 881
Graphics: Device-1: NVIDIA MCP89 [GeForce 320M] vendor: Apple driver: N/A bus-ID: 02:00.0
Device-2: Apple Built-in iSight type: USB driver: uvcvideo bus-ID: 1-6:2
Display: server: 1.20.11 driver: loaded: vesa unloaded: fbdev,modesetting
resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: NVIDIA MCP89 High Definition Audio driver: snd_hda_intel v: kernel
bus-ID: 00:08.0
Sound Server-1: ALSA v: k5.11.16-arch1-1 running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.26 running: no
Network: Device-1: NVIDIA MCP89 Ethernet vendor: Apple driver: forcedeth v: kernel port: 22a0
bus-ID: 00:09.0
IF: enp0s9 state: down mac:
Device-2: Broadcom BCM43224 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl
v: kernel port: 2280 bus-ID: 01:00.0
IF: wlan0 state: up mac:
Bluetooth: Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
bus-ID: 4-6.3:7
Report: This feature requires one of these tools: hciconfig/bt-adapter
Drives: Local Storage: total: 111.79 GiB used: 92.5 GiB (82.7%)
ID-1: /dev/sda vendor: PNY model: CS900 120GB SSD size: 111.79 GiB
Partition: ID-1: / size: 108.98 GiB used: 92.5 GiB (84.9%) fs: ext4 dev: /dev/dm-0
mapped: luks-56162266-4f05-420d-b5b4-75b25a7c43fe
ID-2: /boot/efi size: 511 MiB used: 424 KiB (0.1%) fs: vfat dev: /dev/sda1
Swap: ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
Sensors: System Temperatures: cpu: 54.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 145 Uptime: 21m Init: systemd Compilers: gcc: 10.2.0 Packages: 873
Shell: Bash v: 5.1.4 inxi: 3.3.03

1 Like

I know i will prolly get told how wrong i am but i’m going to say it anyway. I would do two things. I would use a lts kernel for starters as the newer kernels have nothing i’m aware of to improve your machine’s performance. lastly i would use a swap partition of 8gb. I don’t think it would hurt anything to do those two things and see how it performs.

OK, thanks for taking the time to repose/suggest. I am a totally newbie to EndeavourOS and Arch. Actually just days! Though I have much experience on different distros. Will keep you and the community informed as to progress/resolution. Cheers!

ok so you can install lts kernel with

sudo pacman -S linux-lts linux-lts-headers

if you have no need of the headrs you can skip that

then sudo grub-mkconfig -o /boot/grub/grub.cfg

no need to uninstall the newer kernel

Installed linux-lts-5.10-33.1-x86_64 kernel and successfully booted. However I lost network WiFi connection. Any ideas about fix?

I did downgraded kernel first, since I have to figure out how adjust swap file!

It looks like your Macbook uses the Nvidia 340xx drivers which are in the AUR. I assume you are running the open source driver nouveau?

You can get more info from the inixi command regarding the graphics if you install the following packages.

yay -S mesa-demos
yay -S dmidecode
yay -S xorg-xdpyinfo

If you run inxi -Ga after installing you’ll see some more info.

1 Like

If you installed the lts kernel you will probably need the broadcom-wl-lts plus lts headers which should already be installed with the lts kernel.

1 Like

Really no need to downgrade. Linux and Linux-Lts can live side by side no problem. Rick has given you all you should need.

Well, really did not mean downgrade. Both kernel 5.11 and LTS 10.5 are side by side. Since I have lost network WIFI connectivity with LTS, I am booting into kernel 5.11 to keep going and find info about solving connectivity issue. Sorry for not being clear on the point.

There is also a broadcom-wl-dkms version?

Installing now. Thanks! Will inform.

Issue resolved!!! The broadcom-wl-dkms version is the answer. Big up to you. What a wonderful community. Regarding no network WIFI connectivity on MacBook 2010 edition.

We’re just getting started. :grin: I have never used any Mac hardware in my lifetime. Mostly PC desktops custom built always & the odd laptop!

I started in the early 90s with/on Mac. Then in 2000 I decided to back to school to learn NETWORKING technologies. Two years in college. I worked in IT … network and desk side sup[port all on PC. Now I am totally on Linux running on 2 old Mac and one Asus. So, I guess I have been on both sides of the fence.

Not sure what desktop you installed but If your system is sitting idle and freezes it could be some hardware going to sleep? WiFi card? Or something else? Not sure but you could start checking some of the power management settings maybe. You may have to look at some logs. (boot logs, dmesg etc) Try to identify i guess what is causing it to freeze. Not sure if it would be network related? You’re the expert there so I’m sure you can determine that. We will try to help if we can.

Well, it running now. I will let it sit idly and see if our efforts paid off. I have turned off all power saving modes, just to isolate any possible power management issues. DE is Xfce.

1 Like

Hardly an expert. But, What? Me Worry! I know what I know because I know it …