LTS kernel not starting

After reading about LTS kernel, I decided to add it to my system.
It’s an old HP Elite 8000 SFF E8400/Quadro 600, legacy bios, so the hardware is definitely not bleeding edge!
It is the only OS, using all the HDD.
I used:
sudo pacman -S linux-lts linux-lts-headers
then
sudo grub-mkconfig -o /boot/grub/grub.cfg
restarted
grub menu looked good - lts choices added at top.
But when I choose it, a start job appears saying something about the kernel is being syncronized.
After 5 mins I gave up and rebooted.
Tried the fallback lts choice - same.
Finally rebooted and used the current kernel - all good.
I’m not hugely worried about trying to problem solve this to death - the current kernel works fine.
But if anyone has a short simple solution, I will try it.

Here is the latest on installing the LTS kernel

Maybe there is a clue there. Maybe the --needed option is necessary?

Pudge

I’m not sure what --needed does
or if it is actually, err, needed.
It wasn’t for this guy: https://www.youtube.com/watch?v=AJgvIco--AU

The —needed means this!

–needed
Do not reinstall the targets that are already up-to-date.

Edit: Your commands were fine. Something else is running at startup. Need some more info.

You could try commands

sudo pacman -Syyu
sudo pacman -S linux-lts linux-lts-headers

If it doesn’t help, please share your /boot/grub/grub.cfg via e.g. pastebin or similar.

Quadro 600 --> nvidia drivers installed?

then you will need to use nvidia-dkms (will build modules against all installed kernels) or nvidia and nvidia-lts !

1 Like

Yes, Nvidia 390.132 driver installed.
If I just install nvidia-dkms and then the lts kernel/header/grub update, would that work?
( It’s 39c here and I’m not in an OS debugging mood - tomorrow will be cooler - I will try it then)

Hi!
Can you try
sudo pacman -S coreutils kmod initramfs --needed
and
sudo mkinitcpio -P && sudo grub-mkconfig -o /boot/grub/grub.cfg just in case?
Then reboot…

I had another go at this.
sudo pacman -Syyu
-all up to date
Tried to install/build nvidia-dkms but only 440.xx version available and not compatible with 390 driver needed by quadro 600
sudo pacman -S coreutils kmod initramfs --needed
ok
sudo mkinitcpio -P
ok
then:
sudo pacman -S linux-lts linux-lts-headers
sudo grub-mkconfig -o /boot/grub/grub.cfg
restarted
grub menu again looked good - lts choices added at top.
the “wait until kernel time syncronized” start job came up…and finished in about 20 seconds…“target system time syncronized”
but a few lines later:
“started TLP system startup/shutdown”
that stayed there for a few minutes
So I reversed back to the current kernel.
I will leave it as is - it seems to be very stable anyway, and if I’m going to see how Arch is, I may as well live a little dangerously!

Out of curiosity, I tried the same process on my other PC, running ArcoLinuxB Plasma.
Exactly the same.
This is an Arch issue.
I understand thet they recently changed how Kernels were handled, but not well enough to know how to deal with this.
Still, it’s not an issue for me.

Does this computer have Nvidia graphics also?I am curious because i have the GTX1060 desktop card and i am running the nvidia-dkms that comes loaded on endeavourOS. I have previously run the standard kernel, the lts kernel and the zen kernel without any issues but that was on earlier versions of the kernel before Arch changed it’s methods. Which Quadro is it the Quadro 600P? What is the other one’s specs. Also what desktop are you running? Mine uses the 440.xx version.

Hi Rick.
Endeavour PC: E8400/4GB RAM/Nvidia Quadro 600/390.132 driver
ArcoLinux PC: i7-2600/8GB/Nvidia Quadro K600/440.44 driver
Both run KDE Plasma

So it’s just the lts kernel you are trying on both? Is the first Quadro a 600P because i don’t see any listing for just 600? I just tried it on mine and it booted up and said lightdm failed and then i tried to enable lightdm but not sure i did that correctly as it didn’t start and then i checked systemctl status and it said it was degraded. I’m sure it works but i just have to figure out what i need to do to make it work. Not sure if you are getting the same thing but i have had this installed before working but it’s been a while. Normally that’s the reason i use the nvidia-dkms because it rebuilds the modules with updates.

Yes, LTS kernel.
I’ve never heard of a 600P - early 600 is plain 600, as per almost every internet source incl Nvidia.
https://www.nvidia.com/object/product-quadro-600-us.html
The recent LightDM failure can be resolved here:


I use SDDM, not LightDM on both.

I am running Cinnamon desktop with lightdm on Nvidia GTX1060. That is why i asked what desktop you were on. There is a P600 and a K600 and a 600 which i now see. So yes it takes the 390.xx driver and the K600 takes the 440.xx driver. I don’t normally run the lts kernel but like i said i have had it installed but it’s been quite some time. I’ll have to look at it again if i really want to get it installed. Some things have changed a bit so i don’t really have an answer. I have been doing a lot of installing and reinstalling so i really haven’t had the lts kernel installed since more than a year ago.

I’m new to Arch, but use older computers.
I thought I’d try the LTS kernel on my oldest - E8400 - PC.
Just to add a bit of insurance.
There was a new kernel this morning - 5.4.7 - so they get updated quickly, but no real benefit on that PC.
I keep a tab open to https://www.archlinux.org/ just to see if any issues have happened, prior to updates.

1 Like

Okay i just loaded the lts kernel and booted up on it.

sudo pacman -S linux-lts linux-lts-headers nvidia-dkms

Now i will check and see if it boots into the normal kernel.

Yes

[rick@cinnamon-pc ~]$ uname -a
Linux cinnamon-pc 5.4.7-arch1-1 #1 SMP PREEMPT Tue, 31 Dec 2019 17:20:16 +0000 x86_64 GNU/Linux
[rick@cinnamon-pc ~]$ 

:grin:

I forgot i had to load the nvidia-dkms before.

I am running an E8500 on one of my other HP computers too but i have 16 GB DDR3 memory in it.

In that case you’ll probably have to use straight nvidia on that one as i think it will bring up the 390.xx version. But that means installing it on both the lts and regular kernel and you’d have to do that when there are kernel updates to my understanding. Because Arch has changed things i’m just not 100% on what the changes mean without doing it and seeing what happens. I just know from previous this is why i switched to dkms so i wouldn’t have to keep doing this as rolling release updates kernels every couple weeks or so.

nvidia-390xx-dkms is there too