Loud buzzing sound coming out of my speakers

Hi everyone, new user here.

I’ve just installed Endeavour with Gnome and I’m generally thrilled. While I haven’t yet done any proper gaming or video editing it appears prime render offloading is woking just fine with wayland and that makes me happy.

While I’m nothing close to an expert, I have been using linux for a few years, I know how to search, troubleshoot and fix most of the issues I’m faced with.

But I’ve come across this one and I can’t do it myself so I’m kindly asking you to help me out.

What I suspect generated this issue is adding options snd_hda_intel index=0 model=dell-headset-multi to /etc/modprobe.d/alsa-base.conf. Now I did this because otherwise I am unable to use my headset’s microphone. Although plugged in, my Razer Kraken’s microphone would not be detected by the system and the built-in one (the one next to the webcam) would be used instead.

This does add the headset microphone to the available inputs and my headset is working as intended.

However, after doing this I would always get a loud buzzing sound coming from my speakers. It will only sound on my desktop speakers and never on the built-in laptop speakers, or the headphones.

On Manjaro, I would always just edit /etc/tlp.conf and change from 1 to 0.


and, if I was not using TLP, I would edit /etc/modprobe.d/snd_hda_intel.conf and this line options snd_hda_intel power_save=0

This would always solve the issue and permanently make the buzzing sound go away.

However, this is no longer working and I assume it is because of pipewire.

Please help.

  Host: endeavour Kernel: 5.17.1-arch1-1 arch: x86_64 bits: 64 Desktop: GNOME
    v: 41.5 Distro: EndeavourOS
  Type: Laptop System: ASUSTeK product: FX503VD v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX503VD v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX503VD.310 date: 07/16/2020
  ID-1: BAT1 charge: 44.5 Wh (100.0%) condition: 44.5/64.4 Wh (69.1%)
    volts: 5.0 min: 15.2
  Info: quad core Intel Core i5-7300HQ [MCP] speed (MHz): avg: 3332
    min/max: 800/3500
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia
    v: 510.60.02
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.0.0
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  Device-3: Intel Bluetooth wireless interface type: USB driver: btusb
  Local Storage: total: 1.14 TiB used: 553.27 GiB (47.3%)
  Processes: 216 Uptime: 29m Memory: 15.51 GiB used: 3 GiB (19.4%)
  Shell: Bash inxi: 3.3.14


Shouldn’t this be easy to test? I’m not on EOS anymore, but on my system if pipewire is acting up I can just disable the three pipewire services and enable the pulseaudio ones.

1 Like

Could you tell me how to do this?

Again, it might be different on EOS. Also my pipewire installation is probably not ‘complete’ (e.g. very rarely it craps out if there is too much stuff going on, this sort of thing never happened on pulseaudio). But here’s what I do:
systemctl --user stop pipewire.service pipewire-pulse.service wireplumber.service

and then to start pulse:
systemctl --user start pulseaudio.socket pulseaudio.service
Some of that might even be redundant but I don’t know.

1 Like

wiki alway good place for info .

this might help if want use Pulseaudio ( Endeavouros default is Pipewire )

1 Like

Thank you.