Loud beeping sound

So there’s this thing on my computer that makes a very loud beep sometimes, usually happens when I press backspace and there’s nothing to delete and things like that. It seems to be a separate speaker from the main one so it doesn’t work with Bluetooth. On arch I was able to delete it by editing “/etc/modprobe.d/blacklist.conf” and adding “blacklist pcspkr” but on endeavouros it does nothing.

I also tried “/etc/modprobe.d/blacklist” and it made no difference. I can temporarilly fix it with “rmmod pcspkr” so it’s just a matter of blacklisting the module.

Have you tried xset b off?

sudo rmmod pcspkr
sudo  nano /etc/modprobe.d/nobeep.conf
# append next line
blacklist pcspkr

Try this command in terminal

su -c 'modprobe -r pcspkr && echo "blacklist pcspkr" >> /etc/modprobe.d/50-blacklist.conf'

Don’t blacklist the speaker, there is probably no need for that. Just change your terminal emulator settings to not beep on the bell event.

If you are using Konsole, the setting is here:

Yes but I’d have to do that on boot so it would still happen in the lock screen

already tried 50-blacklist.conf, no difference.

its not in the terminal. It’s in the login screen, the start menu, firefox. plus removing the module always worked on arch and it feels a lot more relyable considering if this beep happens at night it will wake everyone up because of how loud and startling it is.

and im on xfce

Still nothing.

Not sure if this would be any different than what has already been suggested but perhaps worth a shot?

Add modprobe.blacklist=pcspkr to the kernel command line.


That did the trick, thanks!

1 Like

You are welcome!
Glad it worked out!

Also, welcome to EnOS’ community @pistachioguy!

:enos_flag: :wave:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.