Lost WiFi on updated kernel on Arm

Updated to latest kernel 6.1.16-3-rpi-ARCH and lost WiFi. Now i must move my setup so i can connect to Ethernet and try to fix it or downgrade. Anyone else have the Pi 400 with this issue?

WiFi is bcm2835-mmc on Raspberry pi 400

see here

I have not had any issues on 5 machines only my Pi 400 arm install WiFi quit working.

kernel be 6.1.19-1-rpi-ARCH. wifi ok on my rpi4.

i no use wifi on rpi but it connect ok.

try update should be out now !

Okay … Thanks.

I can’t get arm to boot on my ssd now. It was originally just WiFi not working. I didn’t just update it. I actually installed a new image from the live ISO and normally i have to add a quirk to boot on a usb drive. now its failing to boot on the usb ssd. I’m going to remove the quirk and try again because i can’t install it if i can’t boot on it. :wink:

Edit: No i think it’s a different problem as it saying the same thing. Get a new e2fsck?

Edit: tried again with latest ISO and quirk. It reports new unsupported Feature_C12 run fsck manually. It won’t complete the boot.

I may have to create a new image for the RPi 4. I will do this today.


1 Like

Before I did anything else, I did an install on uSD ext4 using the Cassini liveISO.
It installed the image, and booted into an OpenBox window and I installed Plasma. It then booted on my RPi 4b using Plasma. Everything worked, and WiFi worked out of the box. No fuss, no muss.

I did the exact same thing using Cassini live ISO. It installed the image, booted into OpenBox window and installed Budgie. It then booted on my RPi 400 using Budgie. Everything worked, and WiFi worked out of the box.

Next I created a new RPi 4 rootfs image and also a new RPi 4 ddimg image.

These are the 3 latest different images for the RPi 4b / 400

  1. rootfs-rpi-20230316 For use with Method one and Method three
  2. ddimg-rpi-20230316 For use with Method two
  3. server-rpi-20230313 For installing a headless LAN server on the RPi 4

These images can be found here:

I am in the process of testing the rootfs image and the ddimg image.

If you use the Cassini liveISO version, after the script formats the uSD or USB SSD, you should see the following in purple.

Downloading image enosLinuxARM-rpi-latest-tar.zst   tag = rootfs-rpi-20230316

If the tag = rootfs-rpi-20230128 it is the older image version.

I will be testing the new images, will give results later.




It’s now working on the sd card. I’m installing it now. Then I’ll install it on the usb ssd to make sure also.


1 Like

Here are some of my test results
All testing done on a RPi 400
All SSD’s installed in Vantec NexStar G4 Model nst-271Cbk USB 3 enclosures

Media   filesystem   DE/WM    method of installation
uSD     ext4         Budgie   Method one Cassini x86_64 liveISO   works fine +WiFi
SSD     btrfs        Plasma   Method one Cassino x86_64 liveISO   works fine +WiFI
SSD     ext4         Sway     Method two Downloaded ISO & burned with RPi-imager

Method two can use RPi-imager as Archlinux AUR has a x86_64 version of RPi-imager
It works great. However, since it is an .ISO so far the ddimage-rpi-20230316 is only available in ext4, no btrfs.


I didn’t have any issues with the new images. Thanks.

1 Like

I am sorry that they got out of date without me realizing it. Bad dev, bad dev.


It’s working like it always had before so I’m good! :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.