Logitech Streamcam not working

I just bought a Logitech Streamcam. It has a resolution of 1920*1080 60fps. It only works at 720p 30fps and i have no sound no matter what i did to fix it. Since i’m a newbie in EOS, If anyone could help it would be very much appreciated !

Some additional information would be useful.

What’s the output of

What programm are you trying to use it with?
Did you install pavucontrol and try to adjust the sound/device settings?
Are you using pulseaudio or pipewire?

1 Like

That’s the output of lsusb :
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 046d:0893 Logitech, Inc. StreamCam
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 18f8:0f97 [Maxxter] Optical Gaming Mouse [Xtrem]
Bus 001 Device 004: ID 1a2c:8016 China Resource Semico Co., Ltd USB Gaming Keyboard
Bus 001 Device 003: ID 2516:0093 Cooler Master Co., Ltd. MH752
Bus 001 Device 002: ID 0781:5567 SanDisk Corp. Cruzer Blade
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’m using guvcview and installed pavucontrol.
I’m also using pulseaudio on guvcview.
Thx in advance …

Fixed the resolution problem based on this link https://davejansen.com/logitech-streamcam-on-linux/ but the sound problem remains … :disappointed:

Verify that the webcam microphone input is available, enabled, and active.

I’d install and use pavucontrol for this - it tends to provide a more detailed and obvious interface than those built into DEs.

1 Like

I’ve already installed pavucontrol as i mentioned above. I have also verified that the webcam microphone input is available, enabled and active.
The thing is that my other headset microphone is not working too …
I see the bar representing the microphone output going up and down in pavucontrol and in guvcview when i press the Cap. Video button, but when i try to play the saved video i hear nothing !
I don’t know what else to do …

This is an additional level of detail you missed from your original post.

What software are you trying to use? Does other software work?

I’m trying to use guvcview and pavucontrol for the audio settings.
I just used audacity and it worked there flawlessly !

Youtube streaming and webcamoid worked also, so it seems that the problem is only with guvcview.

Maybe it works, if you adjust the settings in guvcview.
Have a look at Audio Controls -> Audio API
Changing from PORTAUDIO to PULSEAUDIO might solve the issue.
You might also want to check input device in the same settings tab.

I’ve tried every possible configuration for Audio Controls in guvcview.
Nothing fixed the problem …

Have you tried pipe-wire?

sudo pacman -S pipewire pipewire-pulse --needed

replace pulse yes


This is built with portaudio support only, and portaudio in the repos depends on JACK. Therefore, unless you have a working JACK setup you might need pulseaudio-jack to connect it to Pulseaudio.

You can also set it up for Pulseaudio. I checked it, before recommending the change in setup earlier.

yay -Qs guvcview
local/guvcview 2.0.6-5
    Simple GTK+ interface for capturing and viewing video from v4l2 devices
local/guvcview-common 2.0.6-5
    Common files for guvcview

Installed from Community Repository.

1 Like

Thank you all guys for your interest and suggestions. I tried every possible combination but nothing worked …

Ah, interesting. libpulse is brought in by ffmpeg, so it’s a “hidden” makedepend.

1 Like

Might be time to report a bug with the upstream project?