Logitech mouse has wrong scroll wheel speed after it goes into power saving (plasma wayland)

So I use the same Logitech wireless mouse for years now. After a few minutes of inactivity the mouse goes into a low power mode and wakes up again on interaction.

Recently I noticed that after said wake up the scroll wheel acceleration is not set properly anymore (very, very slow scrolling).

Turning the mouse off and on again or plugging in the WLAN dongle again fixes the issue.

Someone seeing a similar behavior?

I remembered I had the similar problem, but this problem happened randomly.

My solution would be:

I disabled my Logitech mouse that should not wake up my PC when the PC is in sleep mode.
And I refreshed and saved the scrolling speed setting in KDE again. The problem most likely does not occur to me.

OK, I tracked it down to the hid_logitech_hidpp module (reloading fixes the issue too) and a kernel error message hidpp_devicenametype_get_count: received protocol error 0x07. The message leads to a wonky kernel behavior in 6.3:


which may already be fixed in 6.4. Let’s wait and see.