Logitech c920 camera detected, but not working

Fresh install of endevouros, gnome version, all updates.

Trying both zoom, and cheese - both show that there’s no webcam

Tried different usb port

It seems to be recognized:

[340929.563256] usb 3-14: USB disconnect, device number 11
[340936.608619] usb 3-14: new high-speed USB device number 12 using xhci_hcd
[340939.161340] usb 3-14: New USB device found, idVendor=046d, idProduct=082d, bcdDevice= 0.11
[340939.161344] usb 3-14: New USB device strings: Mfr=0, Product=2, SerialNumber=1
[340939.161346] usb 3-14: Product: HD Pro Webcam C920
[340939.161347] usb 3-14: SerialNumber: 4392943F

I’ve never had an issue with this webcam immediately being recognized on other flavors of linux (ubuntu/fedora)

I don’t see much advice on what to do here

v4l2-ctl --list-devices 

looks like you are not the only one…
And cheese is also known to be cheesy :wink: can you try qt-v4l-test ( qv4l2 ) utility?
or something like vlc or mpv av://video4linux2:/dev/video0

1 Like
$ sudo v4l2-ctl --list-devices
Cannot open device /dev/video0, exiting.

The best GUI to test webcams (in my experience) is guvcview. It used to work for me, whenever other programs did not.

1 Like

I get an error of
“no video device (/dev/video0) found”

I can confirm that the webcam does work if I boot from windows on the same device, so I feel it’s not a webcam issue.

What is the output of yay -Qs v4l?

1 Like
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: new high-speed USB device number 8 using xhci_hcd
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: New USB device found, idVendor=0c45, idProduct=636d, bcdDevice= 1.00
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: New USB device strings: Mfr=2, Product=1, SerialNumber=3
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: Product: PC-LM1E
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: Manufacturer: PC-LM1E
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: SerialNumber: PC-LM1E
Nov 05 17:56:11 buildsystem kernel: usb 3-7.2: Found UVC 1.00 device PC-LM1E (0c45:636d)
Nov 05 17:56:11 buildsystem kernel: input: PC-LM1E: PC-LM1E as /devices/pci0000:00/0000:00:14.0/usb3/3-7/3-7.2/3-7.2:1.0/input/input28

is the output on journal for successfully enable a webcam…
yours missing the last two lines.
it basically only needs v4l-utils installed.

should show something like this for your device:

[ 5.500934] input: HD Pro Webcam C920 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0/input/input2
[ 5.504531] usbcore: registered new interface driver uvcvideo

Do you try booting on LTS Kernel?

lists the device eas working too …

1 Like

I know this. I was just asking, because it might be the case that v4l2loopback-dkms is installed. This might prevent the cam from being correctly detected.

1 Like


$ yay -Qs v4l
local/guvcview 2.0.7-1
    Simple GTK+ interface for capturing and viewing video from v4l2 devices
local/v4l-utils 1.22.1-1
    Userspace tools and conversion library for Video 4 Linux

Thanks for all your help everyone, it’s working now…

@joekamprad - your comment about the lts kernel triggered me to do an update and I moved from 5.14.14 to 5.14.16 and it works now. I’m a bozo, I don’t know why I didn’t try that first, but I guess something must have been off in 5.14.14? Just for info everything that was updated (in case it’s something else I’m not thinking of)…

Packages (24) ell-0.45-1  eos-bash-shared-1.10.15-1  glib2-2.70.1-1
              glib2-docs-2.70.1-1  gst-plugins-bad-1.18.5-3
              gst-plugins-bad-libs-1.18.5-3  harfbuzz-3.1.0-1
              harfbuzz-icu-3.1.0-1  iana-etc-20211025-1  iso-codes-4.8.0-1
              iwd-1.19-1  libcap-2.60-1  libgpg-error-1.43-1  libheif-1.12.0-2
              linux-5.14.16.arch1-1  linux-firmware-20211027.1d00989-1
              linux-headers-5.14.16.arch1-1  osinfo-db-20211013-1
              r8168-8.049.02-32  unzip-6.0-15
              virtualbox-host-modules-arch-6.1.28-4  vte-common-0.66.1-1
              vte3-0.66.1-1  webkit2gtk-2.34.1-2

Total Download Size:    370.33 MiB
Total Installed Size:  1174.62 MiB
Net Upgrade Size:         6.12 MiB

yes, the 5.14.14 had some issues seems 5.14.16 has solved some of them :wink:
And … 5.15 is already in testing :sunglasses:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.