Login trouble - please help!

Hi guys!

I installed Endeavour this week and was loving it until today. I have the Xfce default plus Deepin. I ran today’s updates from the Xfce and was asked to reboot. After the reboot I can no longer log into Xfce and while it does let me log into Deepin, it has no sound and I can’t open any browser. How can this be fixed? Thanks in advance!

What happens when you try to login to the Xfce desktop? Does the screen come up like normal to type your password?

Thanks for the reply. When I try to login it just goes back to asking me for the password once again.

Have you tried

  • logging into tty?
  • disabling the display manager (lightdm I assume) and starting XFCE manually?
  • downgrading packages after updating which the problems first occured?
  • uninstalling one of the DEs?
  • googling the problem?

edit: that’s just how I would approach it. If you need help with any of the steps - just ask. But honestly I’d just get rid of Deepin first and see whether some conflict was causing it, because it may be very complicated to debug.


Thanks Tasia! I will look into each of those options you suggested.