Login screen hangs after successful login, and barely responding afterwards

I have this weird issue, where after I turn on the computer and I enter the correct password (entering wrong password shows wrong password quickly), the screen just hangs for a couple of minutes.

Usually it’ll go back to login screen, but after a few tries it’ll log me in and very slowly load the desktop.

That was for a couple of days, but today it got worse:
after finally loading the desktop it barely respond, or very slowly, and the cp fans are very loud.

I’m using Gnome as DE, but it happened when I tired logging in to i3 (I have it installed), and also happened when logging in to another user.
the gnome extensions are all turned off atm and it’s still happening.

I’m trying to run inxi -FAZ --no-host | eos-sendlog but it’s been like 15 minutes not responding.
EDIT: after like 50 minutes the cp responds a bit better, was able to run the command:
http://ix.io/4Mey

When the issue first started showing up I checked to see if I installed any new programs and nothing came to mind.

Welcome to the forum! :smile:

Can you start a TTY by pressing

Ctrl-Alt-F3

?
If yes, then you probably can login and run commands to send logs.

tried now: yes I can.
which logs should I send?

I tried journalctl - b before, but there was too many lines and I didn’t know what to look for.

Latest journal is good: sudo journalctl -b -0 | eos-sendlog
This returns an address, please show it here. Or look at it first without eos-sendlog…

I saw you have nouveau as GPU driver. You may want to change that using nvidia-inst. And to choose the GPU, you need to add some switcher app, e.g. Optimus manager, or blacklist the other GPU.
See more info in our wiki, or the Arch wiki.

eos-sendlog didn’t print anything…
so I had to save the output manually to a file and then upload it…
anyway here it is
https://file.io/J9ckNy019fEX

hope it’s okay. couldn’t upload directly here it only allows images.

could you elaborate a little further? I didn’t understand half the words :sweat_smile:
thanks!

You have two graphics cards (GPUs), 1 from Intel and 1 from Nvidia. Usually Intel works well, but with two cards you probably want to choose which one to use.

You can do this in a couple of ways:

  1. blacklisting the driver you will not use
  2. using an additional GPU switching software

In case 1. you can blacklist either nouveau (Nvidia) or i915 (Intel). look at the Arch wiki how to blacklist, should be quite easy to find.
I’d suggest blacklisting nouveau as a good starting point (later you may want to use alternative 2). Nouveau seemed to cause lots of trouble on your log.

In case 2. you install one of the many GPU switching apps, e.g. optimus manager. The wikis I mentioned above have lots of info about this too. It is a good idea to read those wikis. :wink:
If you choose this alternative, you should install nvidia-dkms. This can be done with the nvidia-inst app. Our wiki can tell more about it too.

Note that two cards gives a bit more complexity, whatever you choose to do. And I might add that Nvidia’s support for Linux could be better…

When there’s two cards, by default does the computer just chooses one or it uses both at the same time?
is there any advantage to having to cards?

And do you think this may cause the problem I’m experiencing?

I’ll have access to my computer again on Sunday, and then I’ll try these solutions see if they work.
In the meantime I’ll read the wikis and expand my knowledge in this field.

thank you so much for your help!

There are pros and cons, as usual.
Good thing is usually the discrete GPU (dGPU) is more efficient.
But bad thing is dGPU typically consumes much more power, and two cards mean more complexity in setting them up.

By default the machine should choose the one to use, and sometimes you can adjust that in the BIOS or some hardware switch.
You can also adjust that with additional software, as mentioned above.

If drivers are not properly set up, naturally that can lead to problems.
Hope you’ll find the proper way to fix the setup the system by reading the links. :sweat_smile:

creating /etc/modprobe.d/blaklist/conf
with “blacklist nouveau” in it solved the problem!

I was prepared for hours of trying and reading articles and thought let’s try it as is for a moment, and it just worked!

thanks again!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.