Login Keyring is not unlocked

When launching an application such as Google Chrome or Opera a box opens up saying the login keyring didn’t get unlocked. Just reinstalled from Nvidia enable ISO.

Edit: Just curious as this never happened before .

Just gave it the password. Odd?

if you have gnome-keyring installed. on chromium based browsers it ask first the password. if you do first time, you must use that password.
but if you give enter the first time and leave it blank , the dialog dont come back.

if you already gave a password you can remove that password and start over to leave blank asswell :slight_smile:

i think you need to remove the .cache of chromium…exact i dont know but is like ressetting, :slight_smile:

1 Like

I remember long time ago at antegos forum there was a similiar problem when using autologin with lightdm.
Despite the fact you didn’t need to type your user and password to login, a popup message appeared when running some programs…
I don’t remember which was the solution.

@ricklinux did you use autologin option? If so, can you test without it in a next install?

This bothered me for many years. I finally found a solution for chromium -based browsers. I’ve posted the link at the bottom of this reply. It is from an ubuntu resource, but works in arch, too, of course.

Note/ Disclaimer: I do not purport to understand the security implications of this solution. If there are security issues, I would request and urge others who are knowledgeable to weigh-in on this thread so that all can weigh the usefulness of the solution in view of their own security concerns.

In your launcher, the command line should be:

/usr/bin/application-name --password-store=basic %U

so, for chromium, it would be:

/usr/bin/chromium --password-store=basic %U

This can also be done in the /usr/share/applications/chromium.desktop file, and change the line from:

Exec=/usr/bin/chromium %U


Exec=/usr/bin/chromium --password-store=basic %U

however, this line gets reset when a new version of the application is installed. In that case, you’ll have to remember to fix that line after every update.

See, http://tipsonubuntu.com/2017/12/20/google-chrome-asks-password-unlock-login-keyring/

No autologin. I think it’s just the settings in the browser to autologin. I turned it off.

1 Like

can only tell this issue was always linked to gnome-keyring , keys get saved to ~/.local/share/keyring , when you remove that, chromium ask again, but just push enter and never comes back

You are probably right. The Gnome keyring is installed but there are settings in Chrome to automatically sign in also so i disabled it. But i had already given it a password to close the box. It was just odd because i haven’t had that before and it kept coming up.