Log out fails at black screen

I hardly ever use the Log Out feature, but I noticed today that it doesn’t work correctly. After clicking the Log Out icon my system freezes on a black screen. At that point I either have to open a terminal and reboot, or use the REISUB method to safely restart my computer.

This always happens now when logged into X11. I tried Wayland and can log out of that just fine, but I don’t use that on a regular basis.

Can someone help me troubleshoot?

System:
  Kernel: 6.6.28-1-lts arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.4 Distro: EndeavourOS
Machine:
  Type: Desktop System: HP product: HP Elite Slice v: N/A
    serial: <superuser required>
  Mobo: HP model: 81C3 v: KBC Version 05.77 serial: <superuser required>
    UEFI: HP v: N25 Ver. 02.61 date: 03/23/2023
CPU:
  Info: quad core model: Intel Core i5-6500T bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 800 min/max: 800/3100 cores: 1: 800 2: 800 3: 800 4: 800
Graphics:
  Device-1: Intel HD Graphics 530 driver: i915 v: kernel
  Device-2: Logitech HD Webcam C510 driver: snd-usb-audio,uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.5-arch1.1
    renderer: Mesa Intel HD Graphics 530 (SKL GT2)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel
  Device-2: Logitech HD Webcam C510 driver: snd-usb-audio,uvcvideo type: USB
  API: ALSA v: k6.6.28-1-lts status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: active
Network:
  Device-1: Intel Ethernet I219-LM driver: e1000e
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 7c:d3:0a:2c:9c:e2
Drives:
  Local Storage: total: 931.51 GiB used: 281.54 GiB (30.2%)
  ID-1: /dev/sda vendor: Western Digital model: WDBNCE0010PNC
    size: 931.51 GiB
Partition:
  ID-1: / size: 898.57 GiB used: 281.37 GiB (31.3%) fs: ext4 dev: /dev/sda2
Swap:
  ID-1: swap-1 type: partition size: 16.55 GiB used: 0 KiB (0.0%)
    dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 41.0 C pch: 44.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.04 GiB used: 2.62 GiB (17.4%)
  Processes: 197 Uptime: 7m Shell: Bash inxi: 3.3.34

Does anyone have any ideas about this issue?

When I was on KDE Plasma 6 I did not have that issue, on Wayland session or X11 session. I’m not sure what might cause that issue. Kernel related, maybe? I’ve not used the lts kernel. Hopefully someone will chime in with assistance. Wish I could be more help.

I’ve tried it withe LTS and the Arch kernel and both get stuck logging out. I think I’ll try creating a new user and will report back what happens.

1 Like

UPDATE:

  1. Logged into an X11 session with either LTS or Arch Kernel my main user account cannot log out. I have to open a terminal and issue the reboot command, enter a TTY and issue systemctl reboot command, or use the REISUB method of restarting.

  2. Logged into a Wayland session with either LTS or Arch kernel my main user account cannot Shut down, Restart, or Log out.

  3. The secondary user account I created operates normally whether it’s in an X11 or Wayland session.

It seems there is something wrong with my user account, but I don’t know how to identify the problem.

Do you have any custom themes installed?
You could also try resetting system settings to default to try find the culprit

Yes, I’ve been running Klassy from the AUR. I’ll uninstall and see what happens. If that doesn’t work I’ll reset all the system settings.

Should just be able to change it to the default theme

I tried that but it didn’t help - anyway I can always reinstall later after I figure out the problem. I tried using System Settings to revert all the changes, but there’s too many and some won’t seem to revert. Isn’t there a file or folder to rename which will reset all my settings to default?

Not too sure, I’m having a look now but I may not find it, I would guess it would be under .config in the home folder but it may be more than one and may not be there. If I find something I’ll get back to you.

Here is some information from the KDE forum, as I thought it may not be so simple to find them.

I renamed my .config folder and rebooted and now everything works properly again. Something got borked but I’m happy it’s back to normal. Now to just customize to how I like it. Thanks!

2 Likes

Cool, just be aware that this will reset other programs as well.

I know, but my sanity is worth it. I’d rather spend a little time setting some things up again than looking for a needle in a haystack.

1 Like

Yer I would probably end up doing the same thing in your situation.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.