Lock Icon on FIles and Folders

Hello there, newbie to EOS here.

I run EOS and Windows 10 in a dual boot mode on an SSD. I use a common HDD, containing some media files to be accessible in both EOS and Windows. But since I made the switch to EOS lately, all my files and folders in the HDD have a yellow circle with a white padlock on it. I can open the files, but not copy, cut, paste or delete them. Since I plan to daily drive EOS, I prefer managing all my files here, rather than log back onto Windows everytime to delete some files. Also right click → properties-> permissions all show Read & Write access for owner, group and others (with the only other remaining options being None, Read only, Write only). Any permanent fix for this ?

Thanks in advance.

Check this out.

Assuming that the shared partition(s) on the HDD ar formatted NTFS, chmod and chown will not work to set the right permissions and ownership for it (them).

Instead you would need to add mount entries for them in /etc/fstab with lines as in the following pattern:

UUID=nnnn    /path/to/mount/point   ntfs-3g   uid=userid,gid=groupid,umask=0022,noauto   0 0

Replacing nnnn with the actual UUID of the partition,
/path/to/mount/point with a mount point of your choice (example /home/username/Data),
userid and groupid with your username.

If you want the partitions to be auto-mounted at boot, remove the noauto option.

Welcome! :rocket: :enos_flag:

Since you can access files via Windows too, I suppose this is NTFS drive.

You cannot access edit/ remove files via Endeavour (or any other distro) if Windows did not shut down properly or if it uses “Fast Startup”. See link below to disable fast startup
https://www.asus.com/support/FAQ/1045548/

As name suggests, booting windows can take slightly longer, but you’re using a ssd and I don’t think the boot times will increase greatly. (I have it disabled on both my systems)

After this, with your HDD mounted on windows, do a shutdown/reboot and now you should be able to access them in Endeavour too.

1 Like

Apologies for the late reply.
Yes, it is formatted as NTFS.

I edited /etc/fstab by opening it in terminal with sudo asbit was read only by default.

After editing, this is what ended up happening.

I don’t know where you went wrong, but the immediate fix would be to use a live usb to chroot into your installation and revert the changes you made to /etc/fstab

On the screen, give your root password (might be the same as your user password if you have not set a root password explicitly).

Then type nano /etc/fstab and comment out the line(s) you have added by putting # at the beginning.
When done press Ctrl-o, enter and ctrl-x to save and exit nano. Now type reboot and press enter.

If you would rather use a live USB, you don’t need in fact chroot to edit the installed system’s /etc/fstab.
Just mount the system partition in the file manager, navigate to /etc/fstab and edit.

When you get back to your system, post the output of

cat /etc/fstab

and with the drive(s) you want to mount connected:

lsblk -fs

and indicate which partitions you want to get mounted at boot via /etc/fstab.