Location of shortcuts to enter/exit TTY

Hello :slight_smile: I just discovered that the TTY shortcuts are different, via pressing Ctrl+Alt+F1 to return into desktop, and the machine hanging. I saw in another thread that F7 can be an alternative, and that does work, but I know for a fact I’ll hit F1 in the future, and don’t want to be rebooting like that immediately after updates. I’m so used to using that shortcut, it’s going to happen, lol. Can I ask where the settings are to change the shortcut back to F1?

systemd runs on TTY1, so you can’t use it interactively. TTY2-6 remain available by default, with TTY7 normally having your DM.


If your system is rebooting when you switch to a TTY/console then there’s a different issue at play.

1 Like

Thanks Jonathan :slight_smile: I’d searched TTY in the wiki, but didn’t get any further. Never encountered this before on arch. Is this due to systemd changes this year? It didn’t reboot the system, but I couldn’t find a way back in, so had no option but to reboot. Sticker on the keys time, lol (joking).

This isn’t new… it has been a thing for a good while. :confused:

Not sure - TTY1 should just give you some boot log output. If you can’t switch back then something is wrong…

Thanks again. TTY7 gets me back in to desktop, but I’m quite befuddled about this change, lol, as I was definitely using TTY1 on Anarchy just last week. That must be set up differently somehow.

I’ve only seen TTY1 be “live” with Gnome builds - FWIW. Everything else I’ve tried has TTY7.

1 Like

I’ve used Anarchy for quite a long time before this week, always F1, and manjaro before that was F1 and where I learnt to use the TTY. No gnome experience, and heard nothing about F7 used in the 3 years I’ve been on Linux. You live and learn, lol. :joy:

I tried to get an Anarchy build going - without much luck. First off, the hi-dpi problem - couldn’t see it to follow the text…which is all there is! Second - I still haven’t figured how they are setting up their boot - and it doesn’t play well with others! Never tried Manjaro - scared off by the fact they modify the Arch stuff before presenting it…

As for the Gnome - I ran into that on Ubuntu and others as well as on EnOS - no idea how they do it, but assumed it was GDDM related vs LightDM…

Yes, the resolution drove me nutso, lol. I don’t understand why, with a whole giant big enormous screen, many linux programs choose the centre pixel, lol. New glasses today, so the binoculars may spend a bit more time in the drawer. :rofl:

I’ve not dual-booted (a brief try way back cured me of that!), so am not sure what they do with boot. Their issues page is on Gitlab now (not super-responsive unfortunately), but they seem to be working away at various things otherwise, so maybe that’ll get fixed along the way.

I didn’t stay on Manjaro long, as the modifying of upstream stuff was causing breakages etc. Works really well with EnOS to not modify stuff, as pure arch get things really right.

Sorry, GDDM related vs LightDM … re the F1/F7?

My Plasma is on F1, always used to be F7 :confused:

Easier on the fingers though :rofl:


F7, or tty7, used to be the default location for the graphical interface for decades :wink:

If you’re running KDE+sddm, you can edit /etc/sddm.conf and change MinimumVT in X11 section.


F1 is fine, easier to reach.

1 Like

When you hit Ctrl-Alt-FX, systemd starts the service getty@ttyX.service, which runs agetty to spawn a console.


Quite surreal when you come from no knowledge or experience at all of F7, yet it’s pretty much standard, lol, I now see. And I agree, F1 is easier on the digits. Used to use KDE, but not the TTY then; it’s been Mate for a long time now, which does the F1 on Anarchy … plenty of shortcut options on Mate for workspaces and sound and moving windows about, but nothing I can see GUI-wise for changing TTY stuff. Oh well, good to learn what works. :+1:t2:

1 Like

I’m used to Plasma being on TTY1.

F7 is difficult to hit in the dark, without tapping on the keyboard and searching for it :smiley:

1 Like

lol, yes :rofl: I just practised seeing if I could find it easily in the dark; nope, takes about 10 seconds, whereas F1 takes just a second!


You don’t have backlit keyboards? I’m surrounded by barbarians! :laughing:


lol haha, mine’s backlit, but I was testing if someone didn’t have that and was in the total dark … mind, there’d be some light from the screen I imagine.

1 Like