Loading inital ramdisk

Hello everyone,

I started the arch linux journey with EOS and it was a pleasant experience.
I configured my grub to launch with the nouveau.modeset=0 paramater otherwise it didn’t boot at all.
But my last boot was stuck on loading initial ramdisk even with nomodeset.

  • I tried to launch with fallback img, didn’t boot too
  • I tried to boot with live USB (EOS installer) and mount my primary partition but it say ‘unknow filesystem type ext4’ so I can’t chroot and regenerate my initramfs

A last thing trouble me, if I boot too much on live USB, it stop to boot correctly, i don’t know why
I tried a fresh install but the problem came back again (I tried with basic linux kernel and zen kernel)

My configuration is :

  • Dell Latitude 5500
  • Bios UEFI secure boot OFF
  • Bootloader : Grub
  • Harddrive : NVME

Thanks for reading

Hello,

I finally figured out how to correct this bug.
I remarked that I can boot if my AC was plugged.
So I booted with my AC plugged, and I regenerated my initramfs (with mkinitcpio but I added in the mkinitcpio preset the module “i915” that correct bugs with intel processor).
Finally I deleted the “intel-ucode.img” in my grub initram options in order to just get my linux-zen.img

After three days it seems to boot normally with and without AC plugged.
Hope it will help someone.

Cheers.

:thinking:

Processor manufacturers release stability and security updates to the processor microcode. These updates provide bug fixes that can be critical to the stability of your system. Without them, you may experience spurious crashes or unexpected system halts that can be difficult to track down.

https://wiki.archlinux.org/title/microcode

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.