Live USB of endeavour is not being detected but other distros are

Hi. So I have been using EndeavourOS on my Intel NUC 11 Enthusiast just fine with no issues. I decided to upgrade to the NUC 12 Enthusiast and followed the same procedures, but I cannot get the Live USB to be detected. Secure boot and fast boot are both off. I tried different USB sticks and redownloading the file from a different mirror and no luck. Simply does not detect it. I tried Fedora KDE to test it out and it detected it no problem. How can I fix this?

Edit: I use balenaetcher to build all my isos

did you check the checksum?
if the file is correct, i would create a bootable stick with another software like rufus and try it out.

I just tried Suse image writer and same problem.

No, I did not check the checksum but I tried multiple different files from different mirrors and have re-flashed several times.

It certainly sounds like a secure boot issue.

I know you said it is disabled but you can you double check?

1 Like

This is all I see, just my SSD. USB no where in sight.

Disabled as far as BIOS shows.

Is legacy boot in your BIOS settings disabled? should be disabled.
What can also play a role is the BIOS/UEFI version, which should be up to date.

I have the latest BIOS version installed. I don’t see a legacy boot option. I attached a photo of the further options I can edit in the boot section of bios. Right now I have exhausted all options of writing the file, I cannot understand why it does not detect it. Ive flashed from macos and linux both. I used balena, suse writer, popsicle. No luck

I tried Ventoy as well. No luck. I also tried to install Arch Linux official ISO, and it’s the same issue as EndeavourOS. Does not detect the live USB.

All other distros such as fedora, mint, Ubuntu, pop_os work. This sucks, I insist on using Endeavour.

Hmm…the distros that work all support secure boot and the ones that don’t work, don’t

I wonder if your BIOS is enforcing secure boot even though it shows it is disabled.

What options do you have inside this menu?

1 Like

Are there any items in “Secure Boot Mode” that you can select beside “Standard”?

What about the “Security” tab? What are the options available there?

Have you tried updating the bios? Are there any updates available?

I may have had a similar problem recently, though I’m not entirely sure if it was with the EOS iso or another distro’s. However, using Rufus completely removed this problem for me. Hope this helps.

Bios is fully up to date.

Unfotunately for me, I don’t have a Windows computer to use Rufus on. I only have access to mac and linux.

Maybe try writing the ISO from the command line with the dd command?

Not sure if this is relevant, but apparently, Intel NUC products only allow GPT partition style for UEFI boot. Is your USB drive using a GPT partition table?