Live mode - usb mouse not working

… this is a bit strange. On the previous version my USB mouse worked just fine

I could test the ISO.

Now I downloaded the latest ISO put it in my USB and tried to move the mouse but it doesn’t work

Actually this has happened with many of the latest distros and I don’t know still if it’s a problem with my mouse or not.

Mint works, puppy works, endeavor doesn’t, kde version of Fedora doesn’t.

I am a bit I the dark

Thanks for any help

Gonna need some more info about your usb stick and how you are putting the iso’s on the usb stick. What program or commands are you using?

If you use Ventoy, you probably need to update ventoy.

1 Like

I use Ventoy, just chekced I have had the latest version

what mouse is it?
Is it wired or wireless?
if you plug something else into the USB port (key or else) is it recognized?

Wireless. I am now typing this from Mint 21, so it works here.

using lusb command it shows as
Bus 001 Device 003: ID 3151:3020 YICHIP Wireless Device

Its a 10 dollar chinese probabaly mouse.

If you have a spare USB stick, you could try using dd to burn the ISO to the stick.
That would rule out any ventoy issue.

Something like:

dd status=progress oflag=sync bs=4M if=$iso of=$targetdisk 

where variables iso is the path to the ISO file, and targetdisk is the USB drive device path. Note that the target USB should not be mounted.

Be careful to have the right target disk device, and make sure to have personal data properly backed up before doing this. :wink:

1 Like

Isnt that the same as writing it with rufus or val. etcher?
Or you mean just install the os to the stick?

I believe it has to do with the kernel or something else I am missing. It doesnt make sense half distros now not recognizing the usb mouse

For what it’s worth (I’m not the most qualified to respond) I had some bad experiences writing the iso with programs like rufus and all… solved with the dd command

actually no its not with ventoy you are just copying the iso over to the USB drive. Ventoy has its own boot that it adds your ISO to.

Programs like etcher, rufus and such take the iso and burn it the USB. This writes blocks and not files. Its very different.

1 Like

How did you see if you were on the latest version, if I might ask?

Essentially the same, although dd simply has been a very reliable burning tool.


I have it downloaded, went to the sire,saw the same version. Downloaded again. Same zip,same kb in size. Run it…well same version in usb stick.,

1 Like

Tried the dd command…couldnt do jacks. :confused:
Anyway,still wondering why on mint it work on latest manjaro and endeavour not.

Note that Arch based systems have the latest versions of nearly all packages, that might explain it.

Maybe the journal can show something about the mouse or usb:

sudo journalctl -b -0 | less

tried the command above,showed a bunch of stuff that obviously…i couldnt copy. No mouse.:stuck_out_tongue:
Anyway,changed my mouse,…now works.