Live iso broken?

So I am trying to do a fresh install of EOS since I’m having problems with trying to get a Wayland session going. I feel like playing around with Linux I have added and moved stuff around which might have messed things up. I also experience pretty bad lag in the beginning when I boot in.

I used balena etcher and the newest live iso to install. I keep getting this message during the boot

When I try to install it sits there for about 10mins show this

After the modules when I get to the partition part when I select my drive it’s sit for about 10 mins then the installer crashes and I’m at the live desktop.

I have used different versions or Balena and Rufus and redownload the EOS iso multiple times. So the only thing I can think of is that the Iso is bad? Maybe I need to use a older iso? If anyone has an idea I would appreciate it. Thanks

The ISO was released back in January. Do you really think that its bad and no one else noticed? Try something like dd to write the image to usb drive, or, if you really want a gui, the gnome-disks tool has never failed me with any ISO. Also, did you check the sha512 checksum of the ISO?

3 Likes

you have nvidia which to my understanding can still have issue’s with Wayland. What problem are you having with wayland?

This is more than likely the issue.

First I will say that many people have downloaded and installed from the ISO so its not that the ISO is bad.

the picture showing the waiting for module. this looks like it is waiting for internet connection (did you set up the wireless?)

1 Like

@Droccord

:point_up: check Endeavour WiKi out (also, read the warnings about Etcher)

:upside_down_face: :upside_down_face: :upside_down_face:

1 Like

etcher is causing issues for a long time already…

1 Like

rufus does work in most case but only if you do not change the ISO with it… what it can do… only if you write in DD or ISO mode it can work properly.

And also if you tried mayn different versions… it still can be the USB stick defective? And the ISO file itself can be corrupted caused by issues with the used hardware.
Older ISO is not a good idea.
And ISO is indeed working i do daily test installs with it. And i do not see any users reporting the same issue here or over the other media… If you are on Windows you can also try this one:

2 Likes

Or you can use Ventoy.

From your screenshots, the problem can be caused by two issues.

  • The USB stick is not functioning correctly.
  • Internet issues.

The live environment does depend on a good internet connection. And over the years I/we have seen some users from some countries have issues connecting to Endeavour repos because their ISPs block the access for some reason.

1 Like

@Droccord
What is the lvm2 mirrors and snap output? I’ve never ever had any issues will etcher. I wouldn’t use Rufus and i wouldn’t recommend ventoy either but others do. There isn’t anything wrong with the ISO unless you have a bad download or created a bad live ISO.

Frankly, I don’t quite understand why one would bother with any GUI when it is so painless to do it from the CLI (just dd it)

1 Like

I feel the same as you, but one can wipe there system without common sense.
dd is my best friend.

1 Like

That’s indeed very true… but I like to make clean installs anyway :rofl:

No but seriously, CLI or GUI, I think the wiki guide is well done and very much “to the point”, I don’t think one could end up with a “corrupted” usb stick following those recommendations.


Oh well, and that indeed @Droccord

Not everyone uses the terminal for everything just because they use a linux distro. I rarely have used dd because I’m not that familiar with it. I use popsicle on EOS and if I’m on Windows i use etcher. Never have i had an issue with creating a live ISO. “To each their own” :wink:

2 Likes

Yeah use Ventoy! I have NEVER he’d any problem with it!
It could also be an bad/iffy USB port try an other one.

1 Like

+1 for Ventoy. There’s even a GUI for the setup process.

…that would be just to write the key then :stuck_out_tongue_closed_eyes:

Keep in mind that I have no real insight on that matter. Even less technical ones :sweat_smile:

I just follow the wiki (don’t really know why I wouldn’t… someone bothered to write it).
(And I’ve always seen different warnings about Etcher in it, for example).

But again… i dunno much… u do u I bet! …as long as it works… just that, look like it doesn’t here :face_in_clouds:

I’ve never had an issue with etcher and I’ve used it from Windows and EOS. I switched to popsicle sometime ago on linux.

I think I might have used dd once outside the EOS usb stick creation… (…if ever :sweat_smile:)
But, yeah, that’s what I use if doing it under Linux (plus it’s the first one in the wiki, lol).

I think I’ve used etcher once or so a long time ago, don’t even know if it was for EOS.
Now, just the “phone home” part is more than enough for me not to use it though.

I used rufus successfully for EOS and others under zindoz.

I’m very confident there’s enough solutions to successfully burn an iso, even if it’s too bad we can’t go buy a CD at the drugstore anymore :sweat_smile:

Maybe we’ll soon know if @Droccord succeeds in doing so!

:+1: :blossom:

1 Like

Thanks everyone for all the help and suggestions. I guess I should have thought about it before saying the ISO is broken.

@eznix
I didn’t check the sha512 checksum, I’ll have to check on how to do that. But I did see that there was a option to do it on Ventoy, which after checking it out it’s a really awesome tool.

After I updated right when plasma 6 released my system I was getting a black DE so I forced it in x11 in the SDDM file. After 3 weeks after they fixed it. I tried switching to the Waylan session at the login screen it would try to log in but be a black screen and then kick back to the login screen and a message about kwin encountered a problem. Only X11 would work.

@joekamprad @s4ndm4n
I did try Ventoy with a new download of EOS from the site and was getting this

I have tried an old USB drive, a new one that I used two times that I bought just before the last endeavors OS release, and a Micro SD card.
I also checked my internet it is wired I also reset it and still encountering the same problem. I had the same internet that I’m using from the last OS update. 50down 15up 15ping

I also tried the USBwriter on a Micro SD with a new EOS download and still getting the LVM2 and snapshot message that takes about 10 minutes to load into the live iOS, in the live iOS when I do “start the install” nothing happens for 10 minutes and then it pops up the screen to try to start installing. I get through with the partitioning part then it freezes up and completely crashes the installation window.

I have not tried DD I’m not really sure what it is I might have to look into that. It’s a bit confusing because the last two Endeavors releases I didn’t have a problem with this. The only thing I could think that might be interfering with something is I updated the firmware on my bios. So maybe it’s something interfering with that?

I used the Ventoy to she sha512 and looks like it checked out good

Sha512 https://imgur.com/gallery/wWEZYh3

I really appreciate everybody’s help I’m trying to learn Linux and not to be too much of a noob

please try to post logs instead of pictures. logs can give us much better insight to what could be going on.
here is a link to learn how
https://discovery.endeavouros.com/category/forum-log-tool-options/

dd is a very straight forward tool. It is the only thing I use to burn a ISO to a USB. I never have problems with Linux distros doing this. Windoz is another issue.

With that said I would not recommend dd if you are not exactly sure of what you are doing. dd can and will remove anything and everything in its way. So its very easy to dd the wrong drive this can be irreversible. Most people opt for Gui tools for this reason.

don’t worry about being a noob we all were at one time. just take your time and read, explore, ask questions and have fun.