Linux ownership not changing using chown

I have a directory and I need to change the permission as it is owned by root.

So I ran this:

chown -R joe Linux\ conf/

This ran without any issues displayed on the console, however when I ls -l the directory, it still shows it is owned by the root owner.

This is especially an issue as wine refuses to work. I am not too sure why its not changing anything?

This is on my external drive. Is this not working cause the parent Directory of Linux conf is owned by the root user?

If it is wonder by root, you need to use sudo. Just be careful not to chown the wrong thing.

I should be getting an error if I didn’t use sudo then.

ANyways I tried sudo and still nothing changes, no errors.

This is how I have mounted my partitions inside /etc/fstab:

   8   │ # Windows
   9   │ /dev/sdb4   /mnt/Windows10  ntfs-3g defaults,discard    0   2
  10   │ /dev/sdc2   /mnt/External   ntfs-3g defaults    0   2

If it is ntfs, fat32, or exfat you can’t change permissions with chown.

You need to mount them with the correct permissions.

Oh, even if I used the ntfs-3g option?

Yes, if they aren’t posix filesystems, you can’t use Linux permission commands.

1 Like

I see thanks man :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.