Lightdm login loop after update

Just updated my laptop with eos bspwm after about a week and am getting a lightdm login loop now. Lightdm wasn’t updated, so I’m not sure where to start with fixing it. Any suggestions?

I am just wondering if you added an entry in .xinitrc and if not, it might help.

exec bspwm

Delete ~/.Xauthority

If there is any error in your dot files, it might cause this loop.
Check journal log, Xorg log and ~/.xsession-errors for relevant messages.

This file is only used when NOT using a Display Manager (TTY login) :wink: :person_shrugging: .

I tried that actually, but no help. Seems to be that xorg is crashing.but the only xorg pkg that got updated was xorg-xkill. I downgraded it but that was no help either.

Is it because you checked the Xorg log, or just guessing?
Similar issues often have to do with login/security issues, or other stuff (if not Xorg, in which case, error messages might give more info).

Well… I use gdm and gnome, when I installed spectrwm it was looping and not logging in. Adding the entry in .xinitrc fixed it :wink:

Don’t ask me why :grin:

I also added all the other startup stuff like nitrogen and picom and it works.

Perhaps could have used .xprofile instead.

Edit: here you go. Perhaps ~/.xprofile maybe worth a try… Just learned something, thanks @petsam

1 Like